summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-11-29 18:05:11 +0100
committerMathieu Othacehe <othacehe@gnu.org>2020-11-29 19:22:05 +0100
commit35a32fefb4695442265809805145b7a262ae4988 (patch)
treed8847c7757849179f75fa615ae798ee0a6b99dde /Makefile.am
parentd9f05c70a6af1087de1717ff20036efa1afef5fb (diff)
downloadguix-35a32fefb4695442265809805145b7a262ae4988.tar.gz
Make "guile-avahi" dependency optional.
* configure.ac (HAVE_GUILE_AVAHI): New conditional.
* Makefile.am (MODULES): Add "guix/avahi.scm" and "guix/scripts/discover.scm"
if HAVE_GUILE_AVAHI is set.
* guix/scripts/publish.scm: Autoload (guix avahi).
* guix/scripts/substitute.scm: Autoload (guix scripts discovery).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 41b366eb75..fc60d15561 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,7 +73,6 @@ include gnu/local.mk
 include po/doc/local.mk
 
 MODULES =					\
-  guix/avahi.scm				\
   guix/base16.scm				\
   guix/base32.scm				\
   guix/base64.scm				\
@@ -257,7 +256,6 @@ MODULES =					\
   guix/import/texlive.scm   			\
   guix/import/utils.scm				\
   guix/scripts.scm				\
-  guix/scripts/discover.scm			\
   guix/scripts/download.scm			\
   guix/scripts/perform-download.scm		\
   guix/scripts/build.scm			\
@@ -321,6 +319,14 @@ MODULES +=					\
 
 endif HAVE_GUILE_SSH
 
+if HAVE_GUILE_AVAHI
+
+MODULES += 					\
+  guix/avahi.scm				\
+  guix/scripts/discover.scm
+
+endif HAVE_GUILE_AVAHI
+
 if BUILD_DAEMON_OFFLOAD
 
 MODULES +=					\