summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-14 21:12:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-15 08:40:00 -0400
commit38d337a5b749713b34568ee55ad747522f26ef94 (patch)
tree0bb5e5a56375830e9846f87b5ff46543a683adee /Makefile.am
parentce9c5fd6baa24e96065943a70f091b9d222e2329 (diff)
downloadguix-38d337a5b749713b34568ee55ad747522f26ef94.tar.gz
tests: Conditionally include tests/go.scm.
The Go importer module requires a recent guile-glib; the test should only be
run when such requirement is met.

* Makefile.am (SCM_TESTS)[HAVE_GUILE_LIB]: Add tests/go.scm only if this
condition is met.

Reported-by: Chris Marusich <cmmarusich@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4cbef5a6e6..e688e21498 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -461,7 +461,6 @@ SCM_TESTS =					\
   tests/git-authenticate.scm			\
   tests/glob.scm				\
   tests/gnu-maintenance.scm			\
-  tests/go.scm					\
   tests/grafts.scm				\
   tests/graph.scm				\
   tests/gremlin.scm				\
@@ -510,6 +509,10 @@ SCM_TESTS =					\
   tests/uuid.scm				\
   tests/workers.scm
 
+if HAVE_GUILE_LIB
+SCM_TESTS += tests/go.scm
+endif
+
 if BUILD_DAEMON_OFFLOAD
 SCM_TESTS  += tests/offload.scm
 else