summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-08 12:06:06 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-09 00:00:49 +0100
commit069d2bf200d5dd2bda6c15e345001a9191abf733 (patch)
tree1b1b15160690342c6035c374d6c42acac32a04df /Makefile.am
parentddb51f3e903ed53ce3c3a88e2af107360f2c51ac (diff)
downloadguix-069d2bf200d5dd2bda6c15e345001a9191abf733.tar.gz
tests: Run 'tests/offload.scm' only when BUILD_DAEMON_OFFLOAD is true.
Fixes:

  guix build -e '(@ (gnu packages package-management) guix-minimal)'

* Makefile.am (SCM_TESTS): Move 'tests/offload.scm' within "if
BUILD_DAEMON_OFFLOAD" conditional.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 51ff9c9ec9..99bdcfa346 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -462,7 +462,6 @@ SCM_TESTS =					\
   tests/monads.scm				\
   tests/nar.scm				\
   tests/networking.scm				\
-  tests/offload.scm				\
   tests/opam.scm				\
   tests/openpgp.scm				\
   tests/packages.scm				\
@@ -499,6 +498,12 @@ SCM_TESTS =					\
   tests/uuid.scm				\
   tests/workers.scm
 
+if BUILD_DAEMON_OFFLOAD
+SCM_TESTS  += tests/offload.scm
+else
+EXTRA_DIST += tests/offload.scm
+endif
+
 SH_TESTS =					\
   tests/guix-build.sh				\
   tests/guix-build-branch.sh			\