summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-22 00:16:47 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-22 00:17:42 +0100
commit7cd1d7bd0cead9999e8d829ddce7abed37f9e9a0 (patch)
tree61bccec91f9ceb8595e521f4909255a3196ec231 /Makefile.am
parentf153d891550986f72a6e10f48cd68fd558569815 (diff)
downloadguix-7cd1d7bd0cead9999e8d829ddce7abed37f9e9a0.tar.gz
gnu: automake: Adjust test suite to lack of /bin/sh.
* gnu/packages/autotools.scm (autoconf-wrapper): New variable.
  (automake): Use AUTOCONF-WRAPPER instead of AUTOCONF.
  Add `automake-skip-amhello-tests.patch' as an input.
  Add #:patches and #:phases arguments.
* gnu/packages/patches/automake-skip-amhello-tests.patch: New file.
* Makefile.am (dist_patch_DATA): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am63
1 files changed, 32 insertions, 31 deletions
diff --git a/Makefile.am b/Makefile.am
index 01190a2e33..54e80cc4ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -136,37 +136,38 @@ GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
 nobase_dist_guilemodule_DATA = $(MODULES)
 
 patchdir = $(guilemoduledir)/gnu/packages/patches
-dist_patch_DATA =					\
-  gnu/packages/patches/bigloo-gc-shebangs.patch		\
-  gnu/packages/patches/binutils-ld-new-dtags.patch	\
-  gnu/packages/patches/cpio-gets-undeclared.patch	\
-  gnu/packages/patches/diffutils-gets-undeclared.patch	\
-  gnu/packages/patches/emacs-configure-sh.patch		\
-  gnu/packages/patches/flex-bison-tests.patch		\
-  gnu/packages/patches/gawk-shell.patch			\
-  gnu/packages/patches/gettext-gets-undeclared.patch	\
-  gnu/packages/patches/glib-tests-desktop.patch		\
-  gnu/packages/patches/glib-tests-homedir.patch		\
-  gnu/packages/patches/glib-tests-timezone.patch	\
-  gnu/packages/patches/glibc-bootstrap-system.patch	\
-  gnu/packages/patches/glibc-no-ld-so-cache.patch	\
-  gnu/packages/patches/guile-1.8-cpp-4.5.patch		\
-  gnu/packages/patches/guile-default-utf8.patch		\
-  gnu/packages/patches/guile-relocatable.patch		\
-  gnu/packages/patches/libevent-dns-tests.patch		\
-  gnu/packages/patches/libtool-skip-tests.patch		\
-  gnu/packages/patches/lsh-guile-compat.patch		\
-  gnu/packages/patches/lsh-no-root-login.patch		\
-  gnu/packages/patches/lsh-pam-service-name.patch	\
-  gnu/packages/patches/m4-gets-undeclared.patch		\
-  gnu/packages/patches/m4-readlink-EINVAL.patch		\
-  gnu/packages/patches/m4-s_isdir.patch			\
-  gnu/packages/patches/make-impure-dirs.patch		\
-  gnu/packages/patches/findutils-absolute-paths.patch	\
-  gnu/packages/patches/perl-no-sys-dirs.patch		\
-  gnu/packages/patches/procps-make-3.82.patch		\
-  gnu/packages/patches/readline-link-ncurses.patch	\
-  gnu/packages/patches/shishi-gets-undeclared.patch	\
+dist_patch_DATA =						\
+  gnu/packages/patches/automake-skip-amhello-tests.patch	\
+  gnu/packages/patches/bigloo-gc-shebangs.patch			\
+  gnu/packages/patches/binutils-ld-new-dtags.patch		\
+  gnu/packages/patches/cpio-gets-undeclared.patch		\
+  gnu/packages/patches/diffutils-gets-undeclared.patch		\
+  gnu/packages/patches/emacs-configure-sh.patch			\
+  gnu/packages/patches/flex-bison-tests.patch			\
+  gnu/packages/patches/gawk-shell.patch				\
+  gnu/packages/patches/gettext-gets-undeclared.patch		\
+  gnu/packages/patches/glib-tests-desktop.patch			\
+  gnu/packages/patches/glib-tests-homedir.patch			\
+  gnu/packages/patches/glib-tests-timezone.patch		\
+  gnu/packages/patches/glibc-bootstrap-system.patch		\
+  gnu/packages/patches/glibc-no-ld-so-cache.patch		\
+  gnu/packages/patches/guile-1.8-cpp-4.5.patch			\
+  gnu/packages/patches/guile-default-utf8.patch			\
+  gnu/packages/patches/guile-relocatable.patch			\
+  gnu/packages/patches/libevent-dns-tests.patch			\
+  gnu/packages/patches/libtool-skip-tests.patch			\
+  gnu/packages/patches/lsh-guile-compat.patch			\
+  gnu/packages/patches/lsh-no-root-login.patch			\
+  gnu/packages/patches/lsh-pam-service-name.patch		\
+  gnu/packages/patches/m4-gets-undeclared.patch			\
+  gnu/packages/patches/m4-readlink-EINVAL.patch			\
+  gnu/packages/patches/m4-s_isdir.patch				\
+  gnu/packages/patches/make-impure-dirs.patch			\
+  gnu/packages/patches/findutils-absolute-paths.patch		\
+  gnu/packages/patches/perl-no-sys-dirs.patch			\
+  gnu/packages/patches/procps-make-3.82.patch			\
+  gnu/packages/patches/readline-link-ncurses.patch		\
+  gnu/packages/patches/shishi-gets-undeclared.patch		\
   gnu/packages/patches/tar-gets-undeclared.patch
 
 bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap