summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-03-17 10:21:31 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-04-04 14:16:43 -0400
commitaff8ce7c742443eaab0b0c6b6f27e6539f3af85f (patch)
treef87d55d39fc52ab37316c9f9c0c8b9162b38d29d /Makefile.am
parent533d1768f47520ac7010adc550b0dd9783ebb011 (diff)
downloadguix-aff8ce7c742443eaab0b0c6b6f27e6539f3af85f.tar.gz
scripts: Add 'publish' command.
* guix/scripts/publish.scm: New file.
* po/guix/POTFILES.in: Add it.
* tests/publish.scm: New file.
* Makefile.am (MODULES): Add script module.
  (SCM_TESTS): Add test module.
* doc/guix.texi ("Invoking guix publish"): New node.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cf709986ed..e15e43fdd4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,6 +105,7 @@ MODULES =					\
   guix/scripts/import/gnu.scm			\
   guix/scripts/import/nix.scm			\
   guix/scripts/environment.scm			\
+  guix/scripts/publish.scm			\
   guix.scm					\
   $(GNU_SYSTEM_MODULES)
 
@@ -180,7 +181,8 @@ SCM_TESTS =					\
   tests/profiles.scm				\
   tests/syscalls.scm				\
   tests/gremlin.scm				\
-  tests/lint.scm
+  tests/lint.scm				\
+  tests/publish.scm
 
 if HAVE_GUILE_JSON