summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-07-15 12:59:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-07-23 09:55:05 +0300
commit12277003d36caf608cbedc57369cbfe1d04e1961 (patch)
treeb4b97abe4a9f49967144163e4494d44694bbf5cf /Makefile.am
parent12cc3da5c189cdbb23b56acf38c46d8efe80cee2 (diff)
downloadguix-12277003d36caf608cbedc57369cbfe1d04e1961.tar.gz
Makefile: Sort scheme tests alphabetically.
* Makefile.am (SCM_TESTS): Sort.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am108
1 files changed, 54 insertions, 54 deletions
diff --git a/Makefile.am b/Makefile.am
index e36f2d9f21..7fa51d17ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -361,77 +361,77 @@ TEST_EXTENSIONS = .scm .sh
 if CAN_RUN_TESTS
 
 SCM_TESTS =					\
+  tests/accounts.scm				\
   tests/base16.scm				\
   tests/base32.scm				\
   tests/base64.scm				\
+  tests/bournish.scm				\
+  tests/builders.scm				\
+  tests/build-utils.scm			\
+  tests/cache.scm				\
+  tests/challenge.scm				\
   tests/channels.scm				\
+  tests/combinators.scm			\
+  tests/containers.scm				\
   tests/cpan.scm				\
   tests/cpio.scm				\
+  tests/cran.scm				\
   tests/crate.scm				\
-  tests/gem.scm					\
-  tests/pki.scm					\
-  tests/print.scm				\
-  tests/sets.scm				\
-  tests/modules.scm				\
-  tests/gnu-maintenance.scm			\
-  tests/substitute.scm				\
-  tests/swh.scm					\
-  tests/builders.scm				\
-  tests/derivations.scm				\
-  tests/glob.scm				\
-  tests/grafts.scm				\
-  tests/ui.scm					\
-  tests/status.scm				\
-  tests/records.scm				\
-  tests/processes.scm				\
-  tests/upstream.scm				\
-  tests/combinators.scm				\
+  tests/cve.scm				\
+  tests/debug-link.scm				\
+  tests/derivations.scm			\
   tests/discovery.scm				\
-  tests/utils.scm				\
-  tests/build-utils.scm				\
-  tests/packages.scm				\
-  tests/snix.scm				\
-  tests/hackage.scm				\
-  tests/cran.scm				\
   tests/elpa.scm				\
-  tests/texlive.scm				\
-  tests/store.scm				\
-  tests/monads.scm				\
+  tests/file-systems.scm			\
+  tests/gem.scm				\
   tests/gexp.scm				\
-  tests/nar.scm					\
-  tests/union.scm				\
-  tests/profiles.scm				\
-  tests/search-paths.scm			\
-  tests/syscalls.scm				\
-  tests/inferior.scm				\
+  tests/glob.scm				\
+  tests/gnu-maintenance.scm			\
+  tests/grafts.scm				\
+  tests/graph.scm				\
   tests/gremlin.scm				\
-  tests/debug-link.scm				\
-  tests/bournish.scm				\
+  tests/hackage.scm				\
+  tests/import-utils.scm			\
+  tests/inferior.scm				\
   tests/lint.scm				\
-  tests/publish.scm				\
-  tests/scripts.scm				\
-  tests/size.scm				\
-  tests/graph.scm				\
-  tests/challenge.scm				\
-  tests/cache.scm				\
-  tests/cve.scm					\
-  tests/workers.scm				\
-  tests/zlib.scm				\
   tests/lzlib.scm				\
-  tests/file-systems.scm			\
-  tests/uuid.scm				\
-  tests/system.scm				\
-  tests/accounts.scm				\
-  tests/services.scm				\
-  tests/scripts-build.scm			\
-  tests/containers.scm				\
+  tests/modules.scm				\
+  tests/monads.scm				\
+  tests/nar.scm				\
   tests/opam.scm				\
+  tests/packages.scm				\
   tests/pack.scm				\
+  tests/pki.scm				\
+  tests/print.scm				\
+  tests/processes.scm				\
+  tests/profiles.scm				\
+  tests/publish.scm				\
   tests/pypi.scm				\
-  tests/import-utils.scm			\
+  tests/records.scm				\
+  tests/scripts.scm				\
+  tests/scripts-build.scm			\
+  tests/search-paths.scm			\
+  tests/services.scm				\
+  tests/sets.scm				\
+  tests/size.scm				\
+  tests/snix.scm				\
+  tests/status.scm				\
   tests/store-database.scm			\
-  tests/store-deduplication.scm			\
-  tests/store-roots.scm
+  tests/store-deduplication.scm		\
+  tests/store-roots.scm			\
+  tests/store.scm				\
+  tests/substitute.scm				\
+  tests/swh.scm				\
+  tests/syscalls.scm				\
+  tests/system.scm				\
+  tests/texlive.scm				\
+  tests/ui.scm					\
+  tests/union.scm				\
+  tests/upstream.scm				\
+  tests/utils.scm				\
+  tests/uuid.scm				\
+  tests/workers.scm				\
+  tests/zlib.scm
 
 SH_TESTS =					\
   tests/guix-build.sh				\