summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-31 14:28:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:28:56 +0200
commit6a2e54236e1b2c428c8fd478ee0f3bd8130703fa (patch)
treeaf70155a2f474d35d90d003f8584b2d9ee0bbaa8 /Makefile.am
parent2cf1e37c109c8d03fae75bc84f7012f3afa956e5 (diff)
parent3d88855dfdcc4c8ce11f494fdf9f0ac1d8eef530 (diff)
downloadguix-6a2e54236e1b2c428c8fd478ee0f3bd8130703fa.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am109
1 files changed, 55 insertions, 54 deletions
diff --git a/Makefile.am b/Makefile.am
index 74113ff9d6..bd27d0079f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -249,6 +249,7 @@ MODULES =					\
   guix/scripts/describe.scm			\
   guix/scripts/system.scm			\
   guix/scripts/system/search.scm		\
+  guix/scripts/system/reconfigure.scm		\
   guix/scripts/lint.scm				\
   guix/scripts/challenge.scm			\
   guix/scripts/import/crate.scm			\
@@ -361,77 +362,77 @@ TEST_EXTENSIONS = .scm .sh
 if CAN_RUN_TESTS
 
 SCM_TESTS =					\
+  tests/accounts.scm				\
   tests/base16.scm				\
   tests/base32.scm				\
   tests/base64.scm				\
+  tests/bournish.scm				\
+  tests/builders.scm				\
+  tests/build-utils.scm			\
+  tests/cache.scm				\
+  tests/challenge.scm				\
   tests/channels.scm				\
+  tests/combinators.scm			\
+  tests/containers.scm				\
   tests/cpan.scm				\
   tests/cpio.scm				\
+  tests/cran.scm				\
   tests/crate.scm				\
-  tests/gem.scm					\
-  tests/pki.scm					\
-  tests/print.scm				\
-  tests/sets.scm				\
-  tests/modules.scm				\
-  tests/gnu-maintenance.scm			\
-  tests/substitute.scm				\
-  tests/swh.scm					\
-  tests/builders.scm				\
-  tests/derivations.scm				\
-  tests/glob.scm				\
-  tests/grafts.scm				\
-  tests/ui.scm					\
-  tests/status.scm				\
-  tests/records.scm				\
-  tests/processes.scm				\
-  tests/upstream.scm				\
-  tests/combinators.scm				\
+  tests/cve.scm				\
+  tests/debug-link.scm				\
+  tests/derivations.scm			\
   tests/discovery.scm				\
-  tests/utils.scm				\
-  tests/build-utils.scm				\
-  tests/packages.scm				\
-  tests/snix.scm				\
-  tests/hackage.scm				\
-  tests/cran.scm				\
   tests/elpa.scm				\
-  tests/texlive.scm				\
-  tests/store.scm				\
-  tests/monads.scm				\
+  tests/file-systems.scm			\
+  tests/gem.scm				\
   tests/gexp.scm				\
-  tests/nar.scm					\
-  tests/union.scm				\
-  tests/profiles.scm				\
-  tests/search-paths.scm			\
-  tests/syscalls.scm				\
-  tests/inferior.scm				\
+  tests/glob.scm				\
+  tests/gnu-maintenance.scm			\
+  tests/grafts.scm				\
+  tests/graph.scm				\
   tests/gremlin.scm				\
-  tests/debug-link.scm				\
-  tests/bournish.scm				\
+  tests/hackage.scm				\
+  tests/import-utils.scm			\
+  tests/inferior.scm				\
   tests/lint.scm				\
-  tests/publish.scm				\
-  tests/scripts.scm				\
-  tests/size.scm				\
-  tests/graph.scm				\
-  tests/challenge.scm				\
-  tests/cache.scm				\
-  tests/cve.scm					\
-  tests/workers.scm				\
-  tests/zlib.scm				\
   tests/lzlib.scm				\
-  tests/file-systems.scm			\
-  tests/uuid.scm				\
-  tests/system.scm				\
-  tests/accounts.scm				\
-  tests/services.scm				\
-  tests/scripts-build.scm			\
-  tests/containers.scm				\
+  tests/modules.scm				\
+  tests/monads.scm				\
+  tests/nar.scm				\
   tests/opam.scm				\
+  tests/packages.scm				\
   tests/pack.scm				\
+  tests/pki.scm				\
+  tests/print.scm				\
+  tests/processes.scm				\
+  tests/profiles.scm				\
+  tests/publish.scm				\
   tests/pypi.scm				\
-  tests/import-utils.scm			\
+  tests/records.scm				\
+  tests/scripts.scm				\
+  tests/scripts-build.scm			\
+  tests/search-paths.scm			\
+  tests/services.scm				\
+  tests/sets.scm				\
+  tests/size.scm				\
+  tests/snix.scm				\
+  tests/status.scm				\
   tests/store-database.scm			\
-  tests/store-deduplication.scm			\
-  tests/store-roots.scm
+  tests/store-deduplication.scm		\
+  tests/store-roots.scm			\
+  tests/store.scm				\
+  tests/substitute.scm				\
+  tests/swh.scm				\
+  tests/syscalls.scm				\
+  tests/system.scm				\
+  tests/texlive.scm				\
+  tests/ui.scm					\
+  tests/union.scm				\
+  tests/upstream.scm				\
+  tests/utils.scm				\
+  tests/uuid.scm				\
+  tests/workers.scm				\
+  tests/zlib.scm
 
 SH_TESTS =					\
   tests/guix-build.sh				\