summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-07 22:41:46 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-07 23:30:38 +0200
commit1165b08f8683b2a8c12753eb6fd26c2451bce81c (patch)
tree207788afef4293414d86f09b10df3d5791b0eaee /Makefile.am
parent5537f2d27925abc05550eff35d13e1347d60dca5 (diff)
downloadguix-1165b08f8683b2a8c12753eb6fd26c2451bce81c.tar.gz
build: Include 'glibc-utf8-locales' in the binary tarball.
* Makefile.am (guix-binary.%.tar.xz): Add 'glibc-utf8-locales' and
'glibc-final' to the 'guix pack' command line.
* doc/guix.texi (Binary Installation): Mention 'etc/profile'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c713d9a3f6..c16a1cf6e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -489,11 +489,13 @@ AM_DISTCHECK_CONFIGURE_FLAGS =			\
   --with-nix-prefix="$(NIX_PREFIX)"		\
   --enable-daemon
 
-# The self-contained tarball.
+# The self-contained tarball.  Add 'glibc-utf8-locales' along with glibc just
+# so 'etc/profile' defines 'GUIX_LOCPATH' pointing to a valid set of locales.
 guix-binary.%.tar.xz:
 	$(AM_V_GEN)GUIX_PACKAGE_PATH=				\
 	tarball=`$(top_builddir)/pre-inst-env guix pack -C xz	\
-	  -s "$*" --localstatedir guix` ;			\
+	  -s "$*" --localstatedir guix glibc-utf8-locales	\
+	  -e  '(@@ (gnu packages commencement) glibc-final)'` ;	\
 	cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"