summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-09 12:51:30 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-09 12:58:43 +0200
commit2a3962660ab877556518c0093aae5c8da7f3bb9f (patch)
tree10f212b71b61093c889ff7d9193590bda5ea066b /Makefile.am
parentaa1c3a0000793873ef31f33f8aa90f5ae1ab8b8d (diff)
downloadguix-2a3962660ab877556518c0093aae5c8da7f3bb9f.tar.gz
maint: Tweak the 'release' target.
* Makefile.am (SUPPORTED_SYSTEMS, GUIXSD_SUPPORTED_SYSTEMS): Use "?="
instead of "=".
(release): Do "git checkout ." in po/ early on.  Abort upon uncommitted
changes.  Print a message at the end.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f574f5f09c..3d91617b0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -561,14 +561,14 @@ SOURCE_TARBALLS =					\
   $(foreach ext,tar.gz,$(PACKAGE_FULL_TARNAME).$(ext))
 
 # Systems supported by Guix.
-SUPPORTED_SYSTEMS = x86_64-linux i686-linux armhf-linux
+SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux armhf-linux
 
 # Guix binary tarballs.
 BINARY_TARBALLS =							\
   $(foreach system,$(SUPPORTED_SYSTEMS),guix-binary.$(system).tar.xz)
 
 # Systems supported by GuixSD.
-GUIXSD_SUPPORTED_SYSTEMS = x86_64-linux #i686-linux
+GUIXSD_SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux
 
 # Prefix of the GuixSD installation image file name.
 GUIXSD_IMAGE_BASE = guixsd-usb-install-$(PACKAGE_VERSION)
@@ -589,10 +589,14 @@ GUIXSD_INSTALLATION_IMAGE_SIZE ?= 950MiB
 # This 'release' target takes care of everything and copies the resulting
 # files to $(releasedir).
 release: distcheck
+	cd po; git checkout .
+	@if ! git diff-index --quiet HEAD; then			\
+	  echo "There are uncommitted changes; stopping." >&2 ;	\
+	  exit 1 ;						\
+	fi
 	$(MKDIR_P) "$(releasedir)"
 	rm -f "$(releasedir)"/*
 	mv $(SOURCE_TARBALLS) "$(releasedir)"
-	cd po; git checkout .
 	$(top_builddir)/pre-inst-env "$(GUILE)"			\
 	   $(top_srcdir)/build-aux/update-guix-package.scm	\
 	   "`git rev-parse HEAD`" "$(PACKAGE_VERSION)"
@@ -622,6 +626,9 @@ release: distcheck
 	  mv "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz.tmp"			\
 	     "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz" ;				\
 	done
+	@echo
+	@echo "Congratulations!  All the release files are now in $(releasedir)."
+	@echo
 
 update-guix-package:
 	git rev-parse HEAD