summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-14 11:46:08 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-14 15:49:49 +0200
commitdfd248648f59af374bf2c74403f0e561464f6afe (patch)
treeaa72294ca1e0038bfbecc14d88c5f395141e9cfb /Makefile.am
parentb6b281a5ba17b4c774590f68738a77993e7fbabd (diff)
downloadguix-dfd248648f59af374bf2c74403f0e561464f6afe.tar.gz
build: 'assert-no-store-file-names' depends on ChangeLog.
This fixes a bug whereby "make distcheck -j4" might invoke
'assert-no-store-file-names' when the temporary $(distdir)/cl-t
exists (and contains store file names), before $(distdir)/ChangeLog has
been created.

* Makefile.am (assert-no-store-file-names): Depend on $(distdir)/ChangeLog.
(dist-hook): Depend on $(distdir)/ChangeLog instead of 'gen-ChangeLog'.
(gen-ChangeLog): Add $(distdir)/ChangeLog left of the colon.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d85b671bb4..4b5a29a72d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -518,7 +518,7 @@ guix-binary.%.tar.xz:
 	cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
 
 
-dist-hook: gen-ChangeLog gen-AUTHORS gen-tarball-version
+dist-hook: $(distdir)/ChangeLog gen-AUTHORS gen-tarball-version
 dist-hook: assert-no-store-file-names
 
 distcheck-hook: assert-binaries-available assert-final-inputs-self-contained
@@ -531,7 +531,7 @@ $(top_srcdir)/.version:
 gen-tarball-version:
 	echo $(VERSION) > "$(distdir)/.tarball-version"
 
-gen-ChangeLog:
+gen-ChangeLog $(distdir)/ChangeLog:
 	$(AM_V_GEN)if test -d .git; then		\
 	  $(top_srcdir)/build-aux/gitlog-to-changelog	\
 	    > $(distdir)/cl-t;				\
@@ -638,7 +638,7 @@ update-guix-package:
 	   "`git rev-parse HEAD`"
 
 # Make sure we're not shipping a file that embeds a local /gnu/store file name.
-assert-no-store-file-names:
+assert-no-store-file-names: $(distdir)/ChangeLog
 	$(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info			\
 	     --exclude=*.info-[0-9] --exclude=*.dot				\
 	     --exclude=*.eps --exclude-dir=bootstrap				\