summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2014-09-01 02:13:21 +0200
committerCyril Roelandt <tipecaml@gmail.com>2014-09-03 02:07:07 +0200
commitb4f5e0e87c112bd4b8425be0c17524ce9c2a85ca (patch)
tree1d31ffa5366fa8e4bf3037dd2ff7ed6bf8d926a9 /Makefile.am
parent5e3b388b51780373e68c19a46a279a809e82d461 (diff)
downloadguix-b4f5e0e87c112bd4b8425be0c17524ce9c2a85ca.tar.gz
scripts: add guix lint
* guix/scripts/lint.scm: New file. Defines a 'lint' tool for Guix packages.
* tests/lint.scm: New file.
* Makefile.am (MODULES, SCM_TESTS): Add them.
* po/guix/Makevars: Update appropriately.
* po/guix/POTFILES.in: Update appropriately.
* doc/guix.texi: Document "guix lint".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fff5958355..371b85c235 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -89,6 +89,7 @@ MODULES =					\
   guix/scripts/authenticate.scm			\
   guix/scripts/refresh.scm			\
   guix/scripts/system.scm			\
+  guix/scripts/lint.scm				\
   guix.scm					\
   $(GNU_SYSTEM_MODULES)
 
@@ -159,7 +160,8 @@ SCM_TESTS =					\
   tests/nar.scm					\
   tests/union.scm				\
   tests/profiles.scm				\
-  tests/syscalls.scm
+  tests/syscalls.scm				\
+  tests/lint.scm
 
 SH_TESTS =					\
   tests/guix-build.sh				\