summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
commite90e0fad1b3ba79d81f02424e143ee6f4f736e8b (patch)
tree2c26190fd9114199b0ef79303e18a61100cab4af /Makefile.am
parent8ea0700d231a8819fc7e8332e9685f0ce15c174e (diff)
parent9ec2a4d3fec44f08a55df9f5f3d1a04b83e7fcf6 (diff)
downloadguix-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 13 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d01c1626e..cda49bd9ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
 # GNU Guix --- Functional package management for GNU
 # Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
 # Copyright © 2013 Andreas Enge <andreas@enge.fr>
-# Copyright © 2015 Alex Kost <alezost@gmail.com>
+# Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
 # Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
 # Copyright © 2016, 2017 Mark H Weaver <mhw@netris.org>
 #
@@ -196,16 +196,17 @@ endif BUILD_DAEMON_OFFLOAD
 # Internal modules with test suite support.
 dist_noinst_DATA = guix/tests.scm guix/tests/http.scm
 
-# Linux-Libre configurations.
-KCONFIGS =					\
-  gnu/packages/linux-libre-4.10-i686.conf	\
-  gnu/packages/linux-libre-4.10-x86_64.conf	\
-  gnu/packages/linux-libre-4.9-i686.conf	\
-  gnu/packages/linux-libre-4.9-x86_64.conf	\
-  gnu/packages/linux-libre-4.4-i686.conf	\
-  gnu/packages/linux-libre-4.4-x86_64.conf	\
-  gnu/packages/linux-libre-4.1-i686.conf	\
-  gnu/packages/linux-libre-4.1-x86_64.conf
+# Auxiliary files for packages.
+AUX_FILES =						\
+  gnu/packages/aux-files/emacs/guix-emacs.el		\
+  gnu/packages/aux-files/linux-libre/4.10-i686.conf	\
+  gnu/packages/aux-files/linux-libre/4.10-x86_64.conf	\
+  gnu/packages/aux-files/linux-libre/4.9-i686.conf	\
+  gnu/packages/aux-files/linux-libre/4.9-x86_64.conf	\
+  gnu/packages/aux-files/linux-libre/4.4-i686.conf	\
+  gnu/packages/aux-files/linux-libre/4.4-x86_64.conf	\
+  gnu/packages/aux-files/linux-libre/4.1-i686.conf	\
+  gnu/packages/aux-files/linux-libre/4.1-x86_64.conf
 
 # Templates, examples.
 EXAMPLES =					\
@@ -216,7 +217,7 @@ EXAMPLES =					\
 GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go $(dist_noinst_DATA:%.scm=%.go)
 
 nobase_dist_guilemodule_DATA =                  \
-  $(MODULES) $(KCONFIGS) $(EXAMPLES)            \
+  $(MODULES) $(AUX_FILES) $(EXAMPLES)            \
   $(MISC_DISTRO_FILES)
 nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm