summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-09 23:52:59 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-09 23:52:59 +0100
commit3259877d3563ac022633fbd8b73134a10567331e (patch)
tree9958721827f6a8ba3f47333bdfa30a7865db8ee0 /Makefile.am
parentd3648e01185dbb3afed85a630b2f8934c68ea143 (diff)
downloadguix-3259877d3563ac022633fbd8b73134a10567331e.tar.gz
store: Add GC-related operations.
* guix/store.scm (gc-action): New enumerate type.
  (read-long-long, read-string-list, write-store-path,
  write-store-path-list, read-store-path-list): New procedures.
  (write-arg): Add support for `store-path' and `store-path-list'.
  (read-arg): Add support for `store-path-list'.
  (define-operation): Add support for multiple-value returns.
  (run-gc, live-paths, dead-paths, collect-garbage, delete-paths): New
  procedures.
  (%long-long-max): New macro.
* tests/store.scm: New file.
* Makefile.am (TESTS): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d52bd389be..7c33fe4b14 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -176,6 +176,7 @@ TESTS =						\
   tests/build-utils.scm				\
   tests/packages.scm				\
   tests/snix.scm				\
+  tests/store.scm				\
   tests/union.scm				\
   tests/guix-build.sh				\
   tests/guix-download.sh			\