summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-14 15:06:46 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-14 15:24:20 +0200
commit661a1d7924e174a28e0e21bf516aa1a8a44dad73 (patch)
treee794ceca18881f189fa0be3a2477cf7a9ccd0182 /Makefile.am
parent0ec5ee94861980a6957d210adf1903ea96202dd9 (diff)
downloadguix-661a1d7924e174a28e0e21bf516aa1a8a44dad73.tar.gz
file-systems: Allow users to specify file system UUIDs as strings.
Fixes <http://bugs.gnu.org/19778>.
Reported by Mark H Weaver <mhw@netris.org>.

* gnu/system/file-systems.scm (%uuid-rx): New variable.
  (string->uuid): New procedure.
  (uuid): New macro.
* tests/file-systems.scm: New file.
* Makefile.am (SCM_TESTS): Add it.
* doc/guix.texi (File Systems): Give an example of UUID.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7059a8f594..5cf9314014 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -203,6 +203,7 @@ SCM_TESTS =					\
   tests/lint.scm				\
   tests/publish.scm				\
   tests/size.scm				\
+  tests/file-systems.scm			\
   tests/containers.scm
 
 if HAVE_GUILE_JSON