summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-07-04 12:27:26 +0300
committerAlex Kost <alezost@gmail.com>2015-07-06 19:00:19 +0300
commita8ac45b19ebb3006ced49b46342e01632829cef2 (patch)
tree15d82d68340fa0aba233ea75c6c37f0dd240786e /Makefile.am
parentf2820e076362a418bfdb486fb4a39e19d517a6d6 (diff)
downloadguix-a8ac45b19ebb3006ced49b46342e01632829cef2.tar.gz
build: Generate 'AUTHORS'.
* build-aux/generate-authors.scm: New file.
* Makefile.am (gen-AUTHORS): New target.
  (dist-hook, .PHONY): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cc0b135de6..44d3b09a82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
 # GNU Guix --- Functional package management for GNU
 # Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 # Copyright © 2013 Andreas Enge <andreas@enge.fr>
+# Copyright © 2015 Alex Kost <alezost@gmail.com>
 #
 # This file is part of GNU Guix.
 #
@@ -363,7 +364,9 @@ guix-binary.%.tar.xz:
 	  "$(top_srcdir)/build-aux/make-binary-tarball.scm" "$*" "$@"
 
 
-dist-hook: sync-descriptions gen-ChangeLog assert-no-store-file-names
+dist-hook: sync-descriptions gen-ChangeLog gen-AUTHORS
+dist-hook: assert-no-store-file-names
+
 distcheck-hook: assert-binaries-available assert-final-inputs-self-contained
 
 sync-descriptions:
@@ -378,6 +381,11 @@ gen-ChangeLog:
 	  mv $(distdir)/cl-t $(distdir)/ChangeLog;	\
 	fi
 
+gen-AUTHORS:
+	$(top_builddir)/pre-inst-env "$(GUILE)"			\
+	  "$(top_srcdir)/build-aux/generate-authors.scm"	\
+	  "$(top_srcdir)" "$(distdir)/AUTHORS"
+
 # Make sure we're not shipping a file that embeds a local /gnu/store file name.
 assert-no-store-file-names:
 	if grep -r --exclude=*.texi --exclude=*.info				\
@@ -397,6 +405,6 @@ assert-final-inputs-self-contained:
 	$(top_builddir)/pre-inst-env "$(GUILE)"				\
 	  "$(top_srcdir)/build-aux/check-final-inputs-self-contained.scm"
 
-.PHONY: sync-descriptions gen-ChangeLog clean-go
+.PHONY: sync-descriptions gen-ChangeLog gen-AUTHORS clean-go
 .PHONY: assert-no-store-file-names assert-binaries-available
 .PHONY: assert-final-inputs-self-contained