summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-12 16:14:25 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-12 16:35:17 +0200
commite793178adbd7d0d2202c0ab4bc6a9fec1df8851f (patch)
tree2fbb198e81d602c082802b8bb231d9aaee367424 /Makefile.am
parentc0cd1b3ea7753fe2826f7a336019000df9dea96f (diff)
downloadguix-e793178adbd7d0d2202c0ab4bc6a9fec1df8851f.tar.gz
build: Generate a ChangeLog file upon "make dist".
* Makefile.am (sync-synopses): New rule, formerly `dist-hook.
  (gen-ChangeLog): New rule.
  (dist-hook): Depend on these two targets.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 69b4af013a..538fad32a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -412,6 +412,18 @@ AM_DISTCHECK_CONFIGURE_FLAGS =			\
   --with-nix-prefix="$(NIX_PREFIX)"		\
   --enable-daemon
 
-dist-hook:
+dist-hook: sync-synopses gen-ChangeLog
+
+sync-synopses:
 	-$(top_builddir)/pre-inst-env $(GUILE)		\
 	   $(top_srcdir)/build-aux/sync-synopses.scm
+
+gen-ChangeLog:
+	if test -d .git; then				\
+	  $(top_srcdir)/build-aux/gitlog-to-changelog	\
+	    > $(distdir)/cl-t;				\
+	  rm -f $(distdir)/ChangeLog;			\
+	  mv $(distdir)/cl-t $(distdir)/ChangeLog;	\
+	fi
+
+.PHONY: sync-synopses gen-ChangeLog