summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-05 16:16:02 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-05 16:33:38 +0100
commit5ec4156bbcaec8337f78411204d59e59e706103b (patch)
treea4cac57c8a683f02216193ee0fbcabf16cb202b5 /Makefile.am
parentc0b726c2112e0e670dc134583b376541c0a3789a (diff)
downloadguix-5ec4156bbcaec8337f78411204d59e59e706103b.tar.gz
tests: Add a manifest for system tests.
The manifest can be passed to 'guix build -m', 'guix weather -m', and so
on.  It can also be passed to an installed 'guix' (without
./pre-inst-env), with the exception so far of installation tests.

* build-aux/run-system-tests.scm: Remove.  Move interesting bits move
to...
* etc/system-tests.scm: ... here.  New file.
* Makefile.am (EXTRA_DIST): Remove 'build-aux/run-system-tests.scm' and
add 'etc/system-tests.scm'.
(check-system): Rewrite to run 'guix build -m etc/system-tests.scm'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index e18c17d8b3..3b951be7f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
 # GNU Guix --- Functional package management for GNU
-# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
 # Copyright © 2013 Andreas Enge <andreas@enge.fr>
 # Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
 # Copyright © 2016, 2018 Mathieu Lirzin <mthl@gnu.org>
@@ -510,9 +510,7 @@ endif !CAN_RUN_TESTS
 
 check-system: $(GOBJECTS)
 	$(AM_V_at)$(top_builddir)/pre-inst-env			\
-	   $(GUILE) --no-auto-compile				\
-	   -e '(@@ (run-system-tests) run-system-tests)'	\
-	   $(top_srcdir)/build-aux/run-system-tests.scm
+	  guix build -m $(top_srcdir)/etc/system-tests.scm -K
 
 # Public keys used to sign substitutes.
 dist_pkgdata_DATA =				\
@@ -543,6 +541,7 @@ EXTRA_DIST +=						\
   scripts/guix.in					\
   etc/guix-install.sh					\
   etc/news.scm						\
+  etc/system-tests.scm					\
   build-aux/build-self.scm				\
   build-aux/compile-all.scm				\
   build-aux/hydra/evaluate.scm				\
@@ -560,7 +559,6 @@ EXTRA_DIST +=						\
   build-aux/test-driver.scm				\
   build-aux/update-guix-package.scm			\
   build-aux/update-NEWS.scm				\
-  build-aux/run-system-tests.scm			\
   d3.v3.js						\
   graph.js						\
   tests/test.drv					\