summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2014-09-30 09:41:59 +0400
committerAlex Kost <alezost@gmail.com>2014-09-30 09:41:59 +0400
commit85054932667d57224dde1d18c381d7d7c0a95dd4 (patch)
tree89eae142cdda1cd653d65f6b5b14a03f872a0111 /Makefile.am
parente596ab0f246af517209142285d6fb0a2716c4007 (diff)
downloadguix-85054932667d57224dde1d18c381d7d7c0a95dd4.tar.gz
build: Build pypi modules only if 'guile-json' is available.
* Makefile.am (MODULES): Wrap 'guix/import/pypi.scm' and
  'guix/scripts/import/pypi.scm' in 'if HAVE_GUILE_JSON'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a1a87c09fe..eba34af4a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -77,7 +77,6 @@ MODULES =					\
   guix/packages.scm				\
   guix/import/utils.scm				\
   guix/import/snix.scm				\
-  guix/import/pypi.scm				\
   guix/scripts/download.scm			\
   guix/scripts/build.scm			\
   guix/scripts/archive.scm			\
@@ -92,7 +91,6 @@ MODULES =					\
   guix/scripts/system.scm			\
   guix/scripts/lint.scm				\
   guix/scripts/import/nix.scm			\
-  guix/scripts/import/pypi.scm			\
   guix.scm					\
   $(GNU_SYSTEM_MODULES)
 
@@ -168,6 +166,10 @@ SCM_TESTS =					\
 
 if HAVE_GUILE_JSON
 
+MODULES +=					\
+  guix/import/pypi.scm				\
+  guix/scripts/import/pypi.scm
+
 SCM_TESTS += tests/pypi.scm
 
 endif