summary refs log tree commit diff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-09-01 19:57:44 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-01 20:00:01 -0400
commita96524cc7d302ad6a8f2cd2e970a148b360f629a (patch)
tree5bc3f8b199a48229692ff8381d7a3a80c3ee571d /Makefile.am
parent385a44bebb4a33517165efa2f75ab376c2263db6 (diff)
downloadguix-a96524cc7d302ad6a8f2cd2e970a148b360f629a.tar.gz
import: gem: Fix minor bug and add unit test.
* guix/import/gem.scm (make-gem-sexp): Properly handle an empty list of
  licenses.  When rendering a list of licenses, cons 'list onto the front of
  the expression.
* tests/gem.scm: New file.
* Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 711181b7cf..9a810e4ebd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -231,7 +231,8 @@ MODULES +=					\
 
 SCM_TESTS += 					\
   tests/pypi.scm				\
-  tests/cpan.scm
+  tests/cpan.scm				\
+  tests/gem.scm
 
 endif