summary refs log tree commit diff
path: root/build-aux/hydra
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-01 22:09:00 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-02 22:16:06 +0200
commita413bc8bd3c2c7d00d8d021a2224a59d26765dad (patch)
tree562034073459bbb574fefda97763c3cb3be312b6 /build-aux/hydra
parent2d51666bd0eee238b70e97f61ad6ce4b958d7362 (diff)
downloadguix-a413bc8bd3c2c7d00d8d021a2224a59d26765dad.tar.gz
hydra: Update Guix job set.
* build-aux/hydra/guix.scm (tarball-package): Remove 'nix-checkout'
  parameter.  Remove 'arguments', 'native-inputs', and 'location'
  fields.  Adjust caller accordingly.
  (hydra-jobs): Remove 'nix-checkout'.
Diffstat (limited to 'build-aux/hydra')
-rw-r--r--build-aux/hydra/guix.scm33
1 files changed, 7 insertions, 26 deletions
diff --git a/build-aux/hydra/guix.scm b/build-aux/hydra/guix.scm
index 3996a0b422..1035f81b4a 100644
--- a/build-aux/hydra/guix.scm
+++ b/build-aux/hydra/guix.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -68,25 +68,10 @@
     (home-page . ,(package-home-page package))
     (maintainers . ("bug-guix@gnu.org"))))
 
-(define (tarball-package checkout nix-checkout)
+(define (tarball-package checkout)
   "Return a package that does `make distcheck' from CHECKOUT, a directory
 containing a Git checkout of Guix."
-  (let ((dist (dist-package guix checkout)))
-    (package (inherit dist)
-      (location (source-properties->location (current-source-location)))
-      (arguments (substitute-keyword-arguments (package-arguments dist)
-                   ((#:phases p)
-                    `(alist-cons-before
-                      'autoreconf 'set-nix-submodule
-                      (lambda _
-                        ;; Tell Git to use the Nix checkout that Hydra gave us.
-                        (zero?
-                         (system* "git" "config" "submodule.nix-upstream.url"
-                                  ,nix-checkout)))
-                      ,p))))
-      (native-inputs `(("git" ,git)
-                       ("graphviz" ,graphviz)
-                       ,@(package-native-inputs dist))))))
+  (dist-package guix checkout))
 
 (define (hydra-jobs store arguments)
   "Return Hydra jobs."
@@ -104,13 +89,9 @@ containing a Git checkout of Guix."
   (define guix-checkout
     (assq-ref arguments 'guix))
 
-  (define nix-checkout
-    (assq-ref arguments 'nix))
-
-  (format (current-error-port) "using checkout ~s (Nix: ~s)~%"
-          guix-checkout nix-checkout)
-  (let ((guix (assq-ref guix-checkout 'file-name))
-        (nix  (assq-ref nix-checkout 'file-name)))
+  (let ((guix (assq-ref guix-checkout 'file-name)))
+    (format (current-error-port) "using checkout ~s (~s)~%"
+            guix-checkout guix)
     `((tarball . ,(cute package->alist store
-                        (tarball-package guix nix)
+                        (tarball-package guix)
                         (%current-system))))))