summary refs log tree commit diff
path: root/build-aux
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-23 19:44:38 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-26 23:11:07 +0200
commit9dd674db017dbdc451cfd35da2dc3ce08db0726a (patch)
treefdab5b2f68ea609b90c80606466ad7702f3f8dbc /build-aux
parent8ac6282c4b97ece43b922a8c1a99a0a8e753c765 (diff)
downloadguix-9dd674db017dbdc451cfd35da2dc3ce08db0726a.tar.gz
daemon: Rename 'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'.
Partly fixes <http://bugs.gnu.org/22459>.
Reported by Jeff Mickey <j@codemac.net> and David Craven <david@craven.ch>.

* nix/libstore/globals.cc (Settings::processEnvironment()): Change
'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'.
* nix/local.mk (libstore_a_CPPFLAGS): Likewise.
* guix/config.scm.in (%config-directory): Likewise.
* build-aux/test-env.in: Likewise.
* gnu/packages/patches/hydra-automake-1.15.patch: Likewise.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/test-env.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/build-aux/test-env.in b/build-aux/test-env.in
index c153763a56..1657556b19 100644
--- a/build-aux/test-env.in
+++ b/build-aux/test-env.in
@@ -69,16 +69,16 @@ then
     fi
 
     # The configuration directory, for import/export signing keys.
-    NIX_CONF_DIR="@GUIX_TEST_ROOT@/etc"
-    if [ ! -d "$NIX_CONF_DIR" ]
+    GUIX_CONFIGURATION_DIRECTORY="@GUIX_TEST_ROOT@/etc"
+    if [ ! -d "$GUIX_CONFIGURATION_DIRECTORY" ]
     then
 	# Copy the keys so that the secret key has the right permissions (the
 	# daemon errors out when this is not the case.)
-	mkdir -p "$NIX_CONF_DIR"
+	mkdir -p "$GUIX_CONFIGURATION_DIRECTORY"
 	cp "@abs_top_srcdir@/tests/signing-key.sec"	\
 	    "@abs_top_srcdir@/tests/signing-key.pub"	\
-	    "$NIX_CONF_DIR"
-	chmod 400 "$NIX_CONF_DIR/signing-key.sec"
+	    "$GUIX_CONFIGURATION_DIRECTORY"
+	chmod 400 "$GUIX_CONFIGURATION_DIRECTORY/signing-key.sec"
     fi
 
     # A place to store data of the substituter.
@@ -100,7 +100,7 @@ then
 	NIX_LOCALSTATE_DIR NIX_LOG_DIR NIX_STATE_DIR NIX_DB_DIR	\
 	NIX_ROOT_FINDER GUIX_BINARY_SUBSTITUTE_URL		\
         GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES			\
-        NIX_CONF_DIR XDG_CACHE_HOME NIXPKGS
+        GUIX_CONFIGURATION_DIRECTORY XDG_CACHE_HOME NIXPKGS
 
     # Launch the daemon without chroot support because is may be
     # unavailable, for instance if we're not running as root.