summary refs log tree commit diff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-17 23:07:01 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-18 00:39:49 +0100
commit36626c556ed75219bce196ac93d148f6b9af984c (patch)
tree518c887e6bf45c647e3793534f4ab87b77ddfad8 /build-aux
parent5461115e8fd9a3181506307b6090716a0d5c202c (diff)
downloadguix-36626c556ed75219bce196ac93d148f6b9af984c.tar.gz
build: Require Guile >= 2.0.9.
* configure.ac: Bump requirement to 2.0.9.
* doc/guix.texi (Requirements): Adjust accordingly.
* README (Requirements): Likewise.
* build-aux/download.scm: Remove workaround for <http://bugs.gnu.org/13095>.
* guix/build/download.scm: Likewise.
(http-fetch)[post-2.0.7?]: Remove.  Remove conditional code for not
POST-2.0.7?.
* guix/http-client.scm:  Remove workaround for <http://bugs.gnu.org/13095>.
(http-fetch)[post-2.0.7?]: Remove.  Remove conditional code for not
POST-2.0.7?.
* guix/serialization.scm (read-latin1-string): Remove mention of 2.0.9.
* tests/nar.scm: Use (ice-9 control).
(let/ec): Remove.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/download.scm5
1 files changed, 0 insertions, 5 deletions
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 8f41f33b14..18b820a153 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -36,11 +36,6 @@
   ;;"http://www.fdn.fr/~lcourtes/software/guix/packages"
   )
 
-;; XXX: Work around <http://bugs.gnu.org/13095>, present in Guile
-;; up to 2.0.7.
-(module-define! (resolve-module '(web client))
-                'shutdown (const #f))
-
 (define (file-name->uri file)
   "Return the URI for FILE."
   (match (string-tokenize file (char-set-complement (char-set #\/)))