summary refs log tree commit diff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-19 22:52:14 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-19 22:52:28 +0100
commit37627ffa89dc318858c14073e6cf238e1f531b36 (patch)
tree2d62f9b64251d7ac50de4c91083b3efffaeeaefc /build-aux
parentdd3b6d66b9c9bb18d00deff7d4ca011dbfbdf122 (diff)
downloadguix-37627ffa89dc318858c14073e6cf238e1f531b36.tar.gz
lint: Fold 'sync-descriptions' script as 'gnu-description' lint checker.
* build-aux/sync-descriptions.scm: Remove.  Move payload to...
* guix/scripts/lint.scm: ... here.
  (escape-quotes, official-gnu-packages*,
  check-gnu-synopsis+description): New procedures.
  (%checkers): Add 'gnu-descriptions'.
* Makefile.am (EXTRA_DIST): Remove build-aux/sync-descriptions.scm.
  (sync-descriptions): Use 'guix lint'.
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/sync-descriptions.scm85
1 files changed, 0 insertions, 85 deletions
diff --git a/build-aux/sync-descriptions.scm b/build-aux/sync-descriptions.scm
deleted file mode 100644
index 6ff549c309..0000000000
--- a/build-aux/sync-descriptions.scm
+++ /dev/null
@@ -1,85 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-;;;
-;;; Report package synopses and descriptions that defer from those found in
-;;; the GNU Womb.
-;;;
-
-(use-modules (guix gnu-maintenance)
-             (guix packages)
-             (guix utils)
-             (guix ui)
-             (gnu packages)
-             (srfi srfi-1)
-             (srfi srfi-26)
-             (ice-9 match))
-
-(define official
-  ;; GNU package descriptors from the Womb.
-  (official-gnu-packages))
-
-(define gnus
-  ;; GNU packages available in the distro.
-  (let ((lookup (lambda (p)
-                  (find (lambda (descriptor)
-                          (equal? (gnu-package-name descriptor)
-                                  (package-name p)))
-                        official))))
-    (fold-packages (lambda (package result)
-                     (or (and=> (lookup package)
-                                (cut alist-cons package <> result))
-                         result))
-                   '())))
-
-(define (escape-quotes str)
-  "Replace any quote character in STR by an escaped quote character."
-  (list->string
-   (string-fold-right (lambda (chr result)
-                        (match chr
-                          (#\" (cons* #\\ #\"result))
-                          (_   (cons chr result))))
-                      '()
-                      str)))
-
-;; Iterate over GNU packages.  Report those whose synopsis defers from that
-;; found upstream.
-(for-each (match-lambda
-           ((package . descriptor)
-            (let ((upstream   (gnu-package-doc-summary descriptor))
-                  (downstream (package-synopsis package))
-                  (loc        (or (package-field-location package 'synopsis)
-                                  (package-location package))))
-              (unless (and upstream (string=? upstream downstream))
-                (format (guix-warning-port)
-                        "~a: ~a: proposed synopsis: ~s~%"
-                        (location->string loc) (package-name package)
-                        upstream)))
-
-            (let ((upstream   (gnu-package-doc-description descriptor))
-                  (downstream (package-description package))
-                  (loc        (or (package-field-location package 'description)
-                                  (package-location package))))
-              (when (and upstream
-                         (not (string=? (fill-paragraph upstream 100)
-                                        (fill-paragraph downstream 100))))
-                (format (guix-warning-port)
-                        "~a: ~a: proposed description:~%     \"~a\"~%"
-                        (location->string loc) (package-name package)
-                        (fill-paragraph (escape-quotes upstream) 77 7))))))
-          gnus)