summary refs log tree commit diff
path: root/build-aux
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-10 17:50:27 -0400
committerMark H Weaver <mhw@netris.org>2015-06-10 17:50:27 -0400
commit14928016556300a6763334d4279c3d117902caaf (patch)
treed0dc262b14164b82f97dd6e896ca9e93a1fabeea /build-aux
parent1511e0235525358abb52cf62abeb9457605b5093 (diff)
parent57cd353d87d6e9e6e882327be70b4d7b5ce863ba (diff)
downloadguix-14928016556300a6763334d4279c3d117902caaf.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/check-final-inputs-self-contained.scm2
-rw-r--r--build-aux/hydra/gnu-system.scm8
-rw-r--r--build-aux/hydra/guix.scm33
-rw-r--r--build-aux/make-binary-tarball.scm3
4 files changed, 11 insertions, 35 deletions
diff --git a/build-aux/check-final-inputs-self-contained.scm b/build-aux/check-final-inputs-self-contained.scm
index ba85c876d2..9b791f2e2d 100644
--- a/build-aux/check-final-inputs-self-contained.scm
+++ b/build-aux/check-final-inputs-self-contained.scm
@@ -77,5 +77,5 @@ refer to the bootstrap tools."
     (set-build-options store #:use-substitutes? #t)
 
     (for-each (cut test-final-inputs store <>)
-              %supported-systems)))
+              %hydra-supported-systems)))
 
diff --git a/build-aux/hydra/gnu-system.scm b/build-aux/hydra/gnu-system.scm
index c612ff1f12..83cc6fb177 100644
--- a/build-aux/hydra/gnu-system.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -78,10 +78,8 @@
     (license . ,(package-license package))
     (home-page . ,(package-home-page package))
     (maintainers . ("bug-guix@gnu.org"))
-
-    ;; Work around versions of 'hydra-eval-guile-jobs' before Hydra commit
-    ;; 61448ca (27 Feb. 2014) which used a default timeout of 2h.
-    (timeout . 72000)))
+    (timeout . ,(or (assoc-ref (package-properties package) 'timeout)
+                    72000)))) ; 20 hours by default
 
 (define (package-job store job-name package system)
   "Return a job called JOB-NAME that builds PACKAGE on SYSTEM."
@@ -159,7 +157,7 @@ system.")
                        (set-guile-for-build (default-guile))
                        (system-disk-image installation-os
                                           #:disk-image-size
-                                          (* 850 MiB))))))
+                                          (* 860 MiB))))))
       '()))
 
 (define (tarball-jobs store system)
diff --git a/build-aux/hydra/guix.scm b/build-aux/hydra/guix.scm
index 3996a0b422..1035f81b4a 100644
--- a/build-aux/hydra/guix.scm
+++ b/build-aux/hydra/guix.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -68,25 +68,10 @@
     (home-page . ,(package-home-page package))
     (maintainers . ("bug-guix@gnu.org"))))
 
-(define (tarball-package checkout nix-checkout)
+(define (tarball-package checkout)
   "Return a package that does `make distcheck' from CHECKOUT, a directory
 containing a Git checkout of Guix."
-  (let ((dist (dist-package guix checkout)))
-    (package (inherit dist)
-      (location (source-properties->location (current-source-location)))
-      (arguments (substitute-keyword-arguments (package-arguments dist)
-                   ((#:phases p)
-                    `(alist-cons-before
-                      'autoreconf 'set-nix-submodule
-                      (lambda _
-                        ;; Tell Git to use the Nix checkout that Hydra gave us.
-                        (zero?
-                         (system* "git" "config" "submodule.nix-upstream.url"
-                                  ,nix-checkout)))
-                      ,p))))
-      (native-inputs `(("git" ,git)
-                       ("graphviz" ,graphviz)
-                       ,@(package-native-inputs dist))))))
+  (dist-package guix checkout))
 
 (define (hydra-jobs store arguments)
   "Return Hydra jobs."
@@ -104,13 +89,9 @@ containing a Git checkout of Guix."
   (define guix-checkout
     (assq-ref arguments 'guix))
 
-  (define nix-checkout
-    (assq-ref arguments 'nix))
-
-  (format (current-error-port) "using checkout ~s (Nix: ~s)~%"
-          guix-checkout nix-checkout)
-  (let ((guix (assq-ref guix-checkout 'file-name))
-        (nix  (assq-ref nix-checkout 'file-name)))
+  (let ((guix (assq-ref guix-checkout 'file-name)))
+    (format (current-error-port) "using checkout ~s (~s)~%"
+            guix-checkout guix)
     `((tarball . ,(cute package->alist store
-                        (tarball-package guix nix)
+                        (tarball-package guix)
                         (%current-system))))))
diff --git a/build-aux/make-binary-tarball.scm b/build-aux/make-binary-tarball.scm
index 0b5dbaf1de..e12bec476c 100644
--- a/build-aux/make-binary-tarball.scm
+++ b/build-aux/make-binary-tarball.scm
@@ -27,9 +27,6 @@
              (gnu system install)
              (ice-9 match))
 
-(define show-what-to-build*
-  (store-lift show-what-to-build))
-
 (define copy-file*
   (lift2 copy-file %store-monad))