summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-04-14 16:18:51 +0900
committerFlorian Pelz <pelzflorian@pelzflorian.de>2024-06-03 00:27:11 +0200
commit2d4af5247057505956e841d396ec78af9f769837 (patch)
tree591b2b9b9518f75376527ac2487d3bc5b00be93d /configure.ac
parent77c79bf5daff2e8041453b7a7112656d6409264b (diff)
downloadguix-2d4af5247057505956e841d396ec78af9f769837.tar.gz
build: Update the POT creation task with the po4a command.
* configure.ac (Documentation translation): Add the po4a program and remove
the po4a-updatepo program.  The PO4A defined here can be used in
Makefiles (e.g. po/doc/local.mk below).  The po4a command integrates the
functionality of po4a-updatepo and is currently recommended for use [1].  The
po4a-updatepo command has been replaced by the po4a command and are not used
from anywhere.
* po/doc/local.mk (%D%/%.pot): Use a po4a command instead of the po4a-updatepo
for the POT generation.  This eliminates the warning of po4a-updatepo;
"po4a-updatepo is deprecated.  The unified po4a(1) program is more convenient
and less error prone."  Here, the file paths are passed using variables.  This
is because the po4a command needs to be executed for each language and each
file.  Dummy values are passed for those that are not needed to update the POT
file.
* po/doc/po4a.cfg: Add a po4a config file for the POT generation.  The po4a
command requires a configulation file.

[1] https://po4a.org/man/man7/po4a.7.php.en#lbAS

Change-Id: Ica39a0d1f77b6a64d37c592ac2e693319443d3c5
Signed-off-by: Florian Pelz <pelzflorian@pelzflorian.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c7b61d56a7..7ef135c0a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -264,8 +264,8 @@ dnl Manual pages.
 AM_MISSING_PROG([HELP2MAN], [help2man])
 
 dnl Documentation translation.
+AM_MISSING_PROG([PO4A], [po4a])
 AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
-AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
 
 AC_MSG_CHECKING([if building from git])
 if test -e .git; then