summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:02 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:26 +0100
commite76bdf8b87920b87a2a2e728c2e40ff24ca39ffe (patch)
treeffcb4e08f2d00acaf670c8344e6a12da6ea39772 /configure.ac
parent81dbd783bd9afabd1d8720c9b60a6a93492bb581 (diff)
downloadguix-e76bdf8b87920b87a2a2e728c2e40ff24ca39ffe.tar.gz
build: Clearly mark Nixpkgs as optional.
* configure.ac: Always show the result of checking for Nixpkgs.  Don't
  warn when Nixpkgs is not found.
* Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Remove `--with-nixpkgs'
  flag.
* guix/utils.scm (%nixpkgs-directory): Use either the compile-time or
  the run-time `NIXPKGS' environment variable.
* release.nix (jobs.tarball, jobs.build): Remove `--with-nixpkgs'
  configure flag.
* README: Mark Nixpkgs as optional.

* distro/packages/databases.scm, distro/packages/guile.scm,
  distro/packages/typesetting.scm: Change uses of `nixpkgs-derivation*'
  to `nixpkgs-derivation', to avoid failing at compile-time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d9a5f07f4f..85bd20e2be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,13 +52,12 @@ AC_ARG_WITH([nixpkgs],
    esac],
   [])
 
+AC_MSG_CHECKING([for Nixpkgs source tree])
 if test -f "$NIXPKGS/default.nix"; then
-   AC_MSG_CHECKING([for Nixpkgs source tree])
    AC_MSG_RESULT([$NIXPKGS])
    AC_SUBST([NIXPKGS])
 else
-   AC_MSG_WARN([Nixpkgs not found; this will prevent most tests from running.])
-   AC_MSG_WARN([Please use `--with-nixpkgs'.])
+   AC_MSG_RESULT([not found])
 fi
 
 AC_ARG_WITH([libgcrypt-prefix],