summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2016-09-07 07:57:38 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-07 16:08:20 +0200
commit96dbc93089723cece1241e51c657f596adf6d3d5 (patch)
treea66b826b47ed87883cc3229f712435637693d5d4 /configure.ac
parente0d7b421f6d7551c15a40e215242d3db7d30682c (diff)
downloadguix-96dbc93089723cece1241e51c657f596adf6d3d5.tar.gz
Add Zsh completion file.
* etc/completion/zsh/_guix: New file.
* Makefile.am (dist_zshcompletion_DATA): New variable.
* configure.ac: Add --with-zsh-completion-dir.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 13a9b6e19f..84287e4289 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,13 @@ AC_ARG_WITH([bash-completion-dir],
   [bashcompletiondir='${sysconfdir}/bash_completion.d'])
 AC_SUBST([bashcompletiondir])
 
+AC_ARG_WITH([zsh-completion-dir],
+  AC_HELP_STRING([--with-zsh-completion-dir=DIR],
+    [name of the Zsh completion directory]),
+  [zshcompletiondir="$withval"],
+  [zshcompletiondir='${datadir}/zsh/site-functions'])
+AC_SUBST([zshcompletiondir])
+
 dnl Better be verbose.
 AC_MSG_CHECKING([for the store directory])
 AC_MSG_RESULT([$storedir])