summary refs log tree commit diff
path: root/daemon.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-22 23:23:38 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-23 00:33:50 +0200
commita7a4e6a4f719da8d0b26d9a60ff8ed42691d263f (patch)
tree8e403c97847edcadcc4da900d7e1c48e675df4bf /daemon.am
parent996ed6acd5586f9db08a9388442acdd044285fe4 (diff)
downloadguix-a7a4e6a4f719da8d0b26d9a60ff8ed42691d263f.tar.gz
Add 'guix-register'.
* nix/guix-register/guix-register.cc, tests/guix-register.sh: New
  files.
* Makefile.am (SH_TESTS)[BUILD_DAEMON]: Add tests/guix-register.sh.
* daemon.am (sbin_PROGRAMS, guix_register_SOURCES,
  guix_register_CPPFLAGS, guix_register_LDADD): New variables.
* test-env.in: Export 'storedir', 'prefix', 'datarootdir', 'datadir',
  and 'localstatedir'.
Diffstat (limited to 'daemon.am')
-rw-r--r--daemon.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/daemon.am b/daemon.am
index 8c21dbc328..77bfe71987 100644
--- a/daemon.am
+++ b/daemon.am
@@ -121,6 +121,7 @@ libstore_a_CXXFLAGS =				\
   $(SQLITE3_CFLAGS) $(LIBGCRYPT_CFLAGS)
 
 bin_PROGRAMS = guix-daemon
+sbin_PROGRAMS = guix-register
 
 guix_daemon_SOURCES =				\
   nix/nix-daemon/nix-daemon.cc			\
@@ -137,6 +138,21 @@ guix_daemon_LDADD =				\
 guix_daemon_headers =				\
   nix/nix-daemon/shared.hh
 
+
+guix_register_SOURCES =				\
+  nix/guix-register/guix-register.cc
+
+guix_register_CPPFLAGS =			\
+  $(libutil_a_CPPFLAGS)				\
+  $(libstore_a_CPPFLAGS)			\
+  -I$(top_srcdir)/nix/libstore
+
+# XXX: Should we start using shared libs?
+guix_register_LDADD =				\
+  libstore.a libutil.a libformat.a -lbz2	\
+  $(SQLITE3_LIBS) $(LIBGCRYPT_LIBS)
+
+
 libexec_PROGRAMS = nix-setuid-helper
 nix_setuid_helper_SOURCES =			\
   nix/nix-setuid-helper/nix-setuid-helper.cc