summary refs log tree commit diff
path: root/daemon.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-02 10:44:20 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-12 21:57:58 +0200
commit419fffa2e84bdcfee13572e1b346a7487926113d (patch)
tree2f072c3072184eeacf19558a1b5e8e7ff03c1b38 /daemon.am
parent04151253e3de87059f9e1a0794a8667b49095917 (diff)
downloadguix-419fffa2e84bdcfee13572e1b346a7487926113d.tar.gz
Add preliminary binary substituter.
* guix/scripts/substitute-binary.scm: New file.
* Makefile.am (MODULES): Add it.
* nix/scripts/substitute-binary.in: New file.
* config-daemon.ac: Produce nix/scripts/substitute-binary.
* daemon.am (nodist_pkglibexec_SCRIPTS): Add
  nix/scripts/substitute-binary.
* guix/store.scm (substitutable-path-info): Use the
  `query-substitutable-path-infos' RPC.
* nix/nix-daemon/guix-daemon.cc (main): Honor `NIX_SUBSTITUTERS'.
* pre-inst-env.in: Set `NIX_SUBSTITUTERS'.
* test-env.in: Leave `NIX_SUBSTITUTERS' unchanged.  Set
  `GUIX_BINARY_SUBSTITUTE_URL, and create
  $NIX_STATE_DIR/substituter-data.
  Run `guix-daemon' within `./pre-inst-env'.
* tests/store.scm ("substitute query"): New test.
Diffstat (limited to 'daemon.am')
-rw-r--r--daemon.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/daemon.am b/daemon.am
index 4f2314b773..069700b1b6 100644
--- a/daemon.am
+++ b/daemon.am
@@ -159,7 +159,8 @@ nix/libstore/schema.sql.hh: nix/libstore/schema.sql
 	           (write (get-string-all in) out)))))"
 
 nodist_pkglibexec_SCRIPTS =			\
-  nix/scripts/list-runtime-roots
+  nix/scripts/list-runtime-roots		\
+  nix/scripts/substitute-binary
 
 EXTRA_DIST +=					\
   nix/sync-with-upstream			\