summary refs log tree commit diff
path: root/distro/packages/attr.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/attr.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/attr.scm')
-rw-r--r--distro/packages/attr.scm77
1 files changed, 0 insertions, 77 deletions
diff --git a/distro/packages/attr.scm b/distro/packages/attr.scm
deleted file mode 100644
index ae0d257dbe..0000000000
--- a/distro/packages/attr.scm
+++ /dev/null
@@ -1,77 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages attr)
-  #:use-module (guix licenses)
-  #:use-module (distro packages perl)
-  #:use-module ((distro packages gettext)
-                #:renamer (symbol-prefix-proc 'guix:))
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public attr
-  (package
-    (name "attr")
-    (version "2.4.46")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://savannah/attr/attr-"
-                          version ".src.tar.gz"))
-      (sha256
-       (base32
-        "07qf6kb2zk512az481bbnsk9jycn477xpva1a726n5pzlzf9pmnw"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:phases
-       (alist-cons-after
-        'configure 'patch-makefile-SHELL
-        (lambda _
-          (patch-makefile-SHELL "include/buildmacros"))
-        (alist-replace
-         'install
-         (lambda _
-           (zero? (system* "make"
-                           "install"
-                           "install-lib"
-                           "install-dev")))
-         (alist-replace
-          'check
-          (lambda _
-            ;; Use the right shell.
-            (substitute* "test/run"
-              (("/bin/sh")
-               (which "bash")))
-
-            (system* "make" "tests" "-C" "test")
-
-            ;; XXX: Ignore the test result since this is dependent on the
-            ;; underlying file system.
-            #t)
-          %standard-phases)))))
-    (inputs `(("perl" ,perl)
-              ("gettext" ,guix:gettext)))
-    (home-page
-     "http://savannah.nongnu.org/projects/attr/")
-    (synopsis
-     "Library and tools for manipulating extended attributes")
-    (description
-     "Portable library and tools for manipulating extended attributes.")
-    (license '(gpl2+ lgpl2.1+))))