summary refs log tree commit diff
path: root/distro/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-12 23:58:01 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-13 00:23:43 +0100
commit25608d640a97c64a6e1f493ca3e46d9168866249 (patch)
treeafb4e8e732647b25c1dd1da319f346dcffcfa7ad /distro/packages/base.scm
parent0db342a590691c8a681e528ebc1664148b5f8579 (diff)
downloadguix-25608d640a97c64a6e1f493ca3e46d9168866249.tar.gz
distro: Patch libc to avoid accessing /etc/ld.so.cache and friends.
* distro/packages/base.scm (glibc): Apply `glibc-no-ld-so-cache.patch'.
  (glibc-final): Inherit GLIBC's inputs.
* distro/packages/patches/glibc-no-ld-so-cache.patch: New file.
* Makefile.am (dist_patch_DATA): Add it.
Diffstat (limited to 'distro/packages/base.scm')
-rw-r--r--distro/packages/base.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/distro/packages/base.scm b/distro/packages/base.scm
index 6088c3d9ce..ed33d61d35 100644
--- a/distro/packages/base.scm
+++ b/distro/packages/base.scm
@@ -511,6 +511,7 @@ used in the GNU system including the GNU/Linux variant.")
 
    (arguments
     `(#:out-of-source? #t
+      #:patches (list (assoc-ref %build-inputs "patch/ld.so.cache"))
       #:configure-flags
       (list "--enable-add-ons"
             "--sysconfdir=/etc"
@@ -550,6 +551,8 @@ used in the GNU system including the GNU/Linux variant.")
                       ;; 4.7.1.
                       ((" -lgcc_s") ""))))
                 %standard-phases)))
+   (inputs `(("patch/ld.so.cache"
+              ,(search-patch "glibc-no-ld-so-cache.patch"))))
    (synopsis "The GNU C Library")
    (description
     "Any Unix-like operating system needs a C library: the library which
@@ -792,7 +795,8 @@ identifier SYSTEM."
      (propagated-inputs `(("linux-headers" ,linux-libre-headers-boot0)))
      (inputs `( ;; A native GCC is needed to build `cross-rpcgen'.
                ("native-gcc" ,@(assoc-ref %boot0-inputs "gcc"))
-               ,@%boot1-inputs)))))
+               ,@%boot1-inputs
+               ,@(package-inputs glibc))))))      ; patches
 
 (define gcc-boot0-wrapped
   ;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the