summary refs log tree commit diff
path: root/distro/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-04 23:16:58 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-04 23:16:58 +0100
commita268f085db226a5bb5723f857d570fd1a6253403 (patch)
treeca6e4fc8d9e0fa3fd63ccaec2b622d2c5f86a298 /distro/packages/base.scm
parentd373e57ea3c1f8ef07a2908e4503b1ad56a3102c (diff)
downloadguix-a268f085db226a5bb5723f857d570fd1a6253403.tar.gz
distro: Add (distro packages compression).
* distro/packages/base.scm (gzip, bzip2, xz): Move to...
* distro/packages/compression.scm: ... here.  New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro/packages/base.scm')
-rw-r--r--distro/packages/base.scm112
1 files changed, 1 insertions, 111 deletions
diff --git a/distro/packages/base.scm b/distro/packages/base.scm
index d5a304098b..6982770128 100644
--- a/distro/packages/base.scm
+++ b/distro/packages/base.scm
@@ -21,6 +21,7 @@
   #:use-module (distro)
   #:use-module (distro packages bash)
   #:use-module (distro packages bootstrap)
+  #:use-module (distro packages compression)
   #:use-module (distro packages gawk)
   #:use-module (distro packages guile)
   #:use-module (distro packages multiprecision)
@@ -134,117 +135,6 @@ files (as archives).")
    (license "GPLv3+")
    (home-page "http://www.gnu.org/software/tar/")))
 
-(define-public gzip
-  (package
-   (name "gzip")
-   (version "1.5")
-   (source (origin
-            (method http-fetch)
-            (uri (string-append "http://ftp.gnu.org/gnu/gzip/gzip-"
-                                version ".tar.gz"))
-            (sha256
-             (base32
-              "18rm80kar7n016g8bsyy1a3zk50i2826xdgs874yh64rzj7nxmdm"))))
-   (build-system gnu-build-system)
-   (synopsis "Gzip, the GNU zip compression program")
-   (arguments
-    ;; FIXME: The test suite wants `less', and optionally Perl.
-    '(#:tests? #f))
-   (description
-    "gzip (GNU zip) is a popular data compression program written by Jean-loup
-Gailly for the GNU project.  Mark Adler wrote the decompression part.
-
-We developed this program as a replacement for compress because of the Unisys
-and IBM patents covering the LZW algorithm used by compress.  These patents
-made it impossible for us to use compress, and we needed a replacement.  The
-superior compression ratio of gzip is just a bonus.")
-   (license "GPLv3+")
-   (home-page "http://www.gnu.org/software/gzip/")))
-
-(define-public bzip2
-  (let ((fix-man-dir
-         ;; Move man pages to $out/share/.
-         '(lambda* (#:key outputs #:allow-other-keys)
-            (with-directory-excursion (assoc-ref outputs "out")
-              (mkdir "share")
-              (rename-file "man" "share"))))
-        (build-shared-lib
-         ;; Build a shared library.
-         '(lambda* (#:key inputs #:allow-other-keys)
-            (zero? (system* "make" "-f" "Makefile-libbz2_so"))))
-        (install-shared-lib
-         '(lambda* (#:key outputs #:allow-other-keys)
-            (let* ((out    (assoc-ref outputs "out"))
-                   (libdir (string-append out "/lib")))
-              (for-each (lambda (file)
-                          (let ((base (basename file)))
-                            (format #t "installing `~a' to `~a'~%"
-                                    base libdir)
-                            (copy-file file
-                                       (string-append libdir "/" base))))
-                        (find-files "." "^libbz2\\.so"))))))
-    (package
-      (name "bzip2")
-      (version "1.0.6")
-      (source (origin
-               (method http-fetch)
-               (uri (string-append "http://www.bzip.org/" version "/bzip2-"
-                                   version ".tar.gz"))
-               (sha256
-                (base32
-                 "1kfrc7f0ja9fdn6j1y6yir6li818npy6217hvr3wzmnmzhs8z152"))))
-      (build-system gnu-build-system)
-      (arguments
-       `(#:modules ((guix build gnu-build-system)
-                    (guix build utils)
-                    (srfi srfi-1))
-         #:phases
-         (alist-cons-before
-          'build 'build-shared-lib ,build-shared-lib
-          (alist-cons-after
-           'install 'fix-man-dir ,fix-man-dir
-           (alist-cons-after
-            'install 'install-shared-lib ,install-shared-lib
-            (alist-delete 'configure %standard-phases))))
-         #:make-flags (list (string-append "PREFIX="
-                                           (assoc-ref %outputs "out")))))
-      (synopsis "high-quality data compression program")
-      (description
-       "bzip2 is a freely available, patent free (see below), high-quality data
-compressor.  It typically compresses files to within 10% to 15% of the best
-available techniques (the PPM family of statistical compressors), whilst
-being around twice as fast at compression and six times faster at
-decompression.")
-      (license "BSD-style")
-      (home-page "http://www.bzip.org/"))))
-
-(define-public xz
-  (package
-   (name "xz")
-   (version "5.0.4")
-   (source (origin
-            (method http-fetch)
-            (uri (string-append "http://tukaani.org/xz/xz-" version
-                                ".tar.gz"))
-            (sha256
-             (base32
-              "1dl35ca8fdss9z2d6y234gxh24ixq904xksizrjmjr5dimwhax6n"))))
-   (build-system gnu-build-system)
-   (synopsis
-    "XZ, general-purpose data compression software, successor of LZMA")
-   (description
-    "XZ Utils is free general-purpose data compression software with high
-compression ratio.  XZ Utils were written for POSIX-like systems, but also
-work on some not-so-POSIX systems.  XZ Utils are the successor to LZMA Utils.
-
-The core of the XZ Utils compression code is based on LZMA SDK, but it has
-been modified quite a lot to be suitable for XZ Utils.  The primary
-compression algorithm is currently LZMA2, which is used inside the .xz
-container format.  With typical files, XZ Utils create 30 % smaller output
-than gzip and 15 % smaller output than bzip2.")
-   (license '("GPLv2+" "LGPLv2.1+"))              ; bits of both
-   (home-page "http://tukaani.org/xz/")))
-
 (define-public patch
   (package
    (name "patch")