summary refs log tree commit diff
path: root/distro/packages/bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-13 00:22:44 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-13 00:23:39 +0100
commit87f5d36630db13fee1f2c0563505dc0938f3787e (patch)
tree9cbbbd3d3c47b647ff7b3131cf8271586e5167a6 /distro/packages/bootstrap.scm
parent62cab99c3297a066f466780bb4d83a4f142538c7 (diff)
downloadguix-87f5d36630db13fee1f2c0563505dc0938f3787e.tar.gz
Remove (guix http) and (guix ftp).
* guix/ftp.scm, guix/http.scm, guix/build/ftp.scm, guix/build/http.scm:
  Remove.
* Makefile.am (MODULES): Likewise.
* tests/builders.scm, distro/packages/base.scm,
  distro/packages/bash.scm, distro/packages/bdw-gc.scm,
  distro/packages/compression.scm, distro/packages/gawk.scm,
  distro/packages/gnupg.scm, distro/packages/gperf.scm,
  distro/packages/guile.scm, distro/packages/libffi.scm,
  distro/packages/libsigsegv.scm, distro/packages/libtool.scm,
  distro/packages/libunistring.scm, distro/packages/lout.scm,
  distro/packages/m4.scm, distro/packages/multiprecision.scm,
  distro/packages/ncurses.scm, distro/packages/perl.scm,
  distro/packages/pkg-config.scm, distro/packages/pth.scm,
  distro/packages/readline.scm, distro/packages/recutils.scm: Use
  `url-fetch' instead of `http-fetch' and `ftp-fetch'.
* distro/packages/bootstrap.scm: Likewise
  (bootstrap-origin): Remove references to `http-fetch' and
  `ftp-fetch'.
* guix.scm (%public-modules): Remove `http' and `ftp'; add `download'.
Diffstat (limited to 'distro/packages/bootstrap.scm')
-rw-r--r--distro/packages/bootstrap.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/distro/packages/bootstrap.scm b/distro/packages/bootstrap.scm
index 95a7de444c..8165be1d53 100644
--- a/distro/packages/bootstrap.scm
+++ b/distro/packages/bootstrap.scm
@@ -19,8 +19,6 @@
 (define-module (distro packages bootstrap)
   #:use-module (distro)
   #:use-module (guix packages)
-  #:use-module (guix ftp)
-  #:use-module (guix http)
   #:use-module (guix download)
   #:use-module (guix build-system)
   #:use-module (guix build-system gnu)
@@ -67,11 +65,7 @@
 
   (let ((orig-method (origin-method source)))
     (origin (inherit source)
-      (method (cond ((eq? orig-method http-fetch)
-                     (boot http-fetch))
-                    ((eq? orig-method ftp-fetch)
-                     (boot ftp-fetch))
-                    ((eq? orig-method url-fetch)
+      (method (cond ((eq? orig-method url-fetch)
                      (boot url-fetch))
                     (else orig-method))))))
 
@@ -207,7 +201,7 @@ $out/bin/guile --version~%"
   (package-from-tarball "bootstrap-binaries"
                         (lambda (system)
                           (origin
-                           (method http-fetch)
+                           (method url-fetch)
                            (uri (string-append
                                  %bootstrap-base-url "/"
                                  system "/static-binaries.tar.xz"))
@@ -226,7 +220,7 @@ $out/bin/guile --version~%"
   (package-from-tarball "binutils-bootstrap"
                         (lambda (system)
                           (origin
-                           (method http-fetch)
+                           (method url-fetch)
                            (uri (string-append
                                  %bootstrap-base-url "/"
                                  system "/binutils-2.22.tar.xz"))
@@ -280,7 +274,7 @@ $out/bin/guile --version~%"
        ("tarball" ,(lambda (system)
                      (bootstrap-origin
                       (origin
-                       (method http-fetch)
+                       (method url-fetch)
                        (uri (string-append %bootstrap-base-url "/"
                                            system "/glibc-2.16.0.tar.xz"))
                        (sha256
@@ -351,7 +345,7 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
        ("tarball" ,(lambda (system)
                      (bootstrap-origin
                       (origin
-                       (method http-fetch)
+                       (method url-fetch)
                        (uri (string-append %bootstrap-base-url "/"
                                            system "/gcc-4.7.2.tar.xz"))
                        (sha256