summary refs log tree commit diff
path: root/distro/packages/ed.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/ed.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/ed.scm')
-rw-r--r--distro/packages/ed.scm53
1 files changed, 0 insertions, 53 deletions
diff --git a/distro/packages/ed.scm b/distro/packages/ed.scm
deleted file mode 100644
index 614b3ae645..0000000000
--- a/distro/packages/ed.scm
+++ /dev/null
@@ -1,53 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages ed)
-  #:use-module (guix licenses)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public ed
-  (package
-    (name "ed")
-    (version "1.5")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append
-            "mirror://gnu/ed/ed-"
-            version
-            ".tar.gz"))
-      (sha256
-       (base32
-        "18gvhyhwpabmgv4lh21lg8vl3z7acdyhh2mr2kj9g75wksj39pcp"))))
-    (build-system gnu-build-system)
-    (arguments '(#:configure-flags '("CC=gcc")))
-    (home-page "http://www.gnu.org/software/ed/")
-    (synopsis
-     "GNU ed, an implementation of the standard Unix editor")
-    (description
-     "GNU ed is a line-oriented text editor.  It is used to create,
-display, modify and otherwise manipulate text files, both
-interactively and via shell scripts.  A restricted version of ed,
-red, can only edit files in the current directory and cannot
-execute shell commands.  Ed is the \"standard\" text editor in the
-sense that it is the original editor for Unix, and thus widely
-available.  For most purposes, however, it is superseded by
-full-screen editors such as GNU Emacs or GNU Moe.")
-    (license gpl3+)))