summary refs log tree commit diff
path: root/distro/packages/gettext.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/gettext.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/gettext.scm')
-rw-r--r--distro/packages/gettext.scm78
1 files changed, 0 insertions, 78 deletions
diff --git a/distro/packages/gettext.scm b/distro/packages/gettext.scm
deleted file mode 100644
index e4d4acc615..0000000000
--- a/distro/packages/gettext.scm
+++ /dev/null
@@ -1,78 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages gettext)
-  #:use-module (guix licenses)
-  #:use-module (distro)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public gettext
-  (package
-    (name "gettext")
-    (version "0.18.1.1")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/gettext/gettext-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "1sa3ch12qxa4h3ya6hkz119yclcccmincl9j20dhrdx5mykp3b4k"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:patches (list (assoc-ref %build-inputs "patch/gets"))
-       #:phases (alist-cons-before
-                 'check 'patch-tests
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   (let ((bash (assoc-ref inputs "bash")))
-                     (substitute* (find-files "gettext-tools/tests"
-                                              "^msgexec-[0-9]")
-                       (("#![[:blank:]]/bin/sh")
-                        (format #f "#!~a/bin/sh" bash)))
-                     (substitute* (find-files "gettext-tools/gnulib-tests"
-                                              "posix_spawn")
-                       (("/bin/sh")
-                        (format #f "~a/bin/bash" bash)))))
-                 %standard-phases)))
-    (inputs
-     `(("patch/gets"
-        ,(search-patch "gettext-gets-undeclared.patch"))))
-    (home-page
-     "http://www.gnu.org/software/gettext/")
-    (synopsis
-     "GNU gettext, a well integrated set of translation tools and documentation")
-    (description
-     "Usually, programs are written and documented in English, and use
-English at execution time for interacting with users.  Using a common
-language is quite handy for communication between developers,
-maintainers and users from all countries.  On the other hand, most
-people are less comfortable with English than with their own native
-language, and would rather be using their mother tongue for day to
-day's work, as far as possible.  Many would simply love seeing their
-computer screen showing a lot less of English, and far more of their
-own language.
-
-GNU `gettext' is an important step for the GNU Translation Project, as
-bit is an asset on which we may build many other steps. This package
-offers to programmers, translators, and even users, a well integrated
-set of tools and documentation. Specifically, the GNU `gettext'
-utilities are a set of tools that provides a framework to help other
-GNU packages produce multi-lingual messages.")
-    (license gpl3))) ; some files are under GPLv2+