summary refs log tree commit diff
path: root/distro/packages/gettext.scm
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-11-23 23:31:26 +0000
committerLudovic Courtès <ludo@gnu.org>2012-11-24 00:52:16 +0100
commitf190f92f9114f42f55d9dde9f71ecd1b9bc29d0d (patch)
tree70c6aa1e6c96664f65f6df6597eefe7e8263c795 /distro/packages/gettext.scm
parentec5288609ba4d8dbe3191379c13e821eb86b11ef (diff)
downloadguix-f190f92f9114f42f55d9dde9f71ecd1b9bc29d0d.tar.gz
distro: Add GNU Gettext.
* distro/packages/gettext.scm,
  distro/packages/patches/gettext-gets-undeclared.patch: New files.
* Makefile.am (MODULES): Add 'gettext.scm'.
  (dist_patch_DATA): Add 'gettext-gets-undeclared.patch'.
Diffstat (limited to 'distro/packages/gettext.scm')
-rw-r--r--distro/packages/gettext.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/distro/packages/gettext.scm b/distro/packages/gettext.scm
new file mode 100644
index 0000000000..ebc25218ab
--- /dev/null
+++ b/distro/packages/gettext.scm
@@ -0,0 +1,64 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages gettext)
+  #:use-module (distro)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public gettext
+  (package
+    (name "gettext")
+    (version "0.18.1.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/gettext/gettext-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "1sa3ch12qxa4h3ya6hkz119yclcccmincl9j20dhrdx5mykp3b4k"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:patches (list (assoc-ref %build-inputs "patch/gets"))))
+    (inputs
+     `(("patch/gets"
+        ,(search-patch "gettext-gets-undeclared.patch"))))
+    (home-page
+     "http://www.gnu.org/software/gettext/")
+    (synopsis
+     "GNU gettext, a well integrated set of translation tools and documentation")
+    (description
+     "Usually, programs are written and documented in English, and use
+English at execution time for interacting with users.  Using a common
+language is quite handy for communication between developers,
+maintainers and users from all countries.  On the other hand, most
+people are less comfortable with English than with their own native
+language, and would rather be using their mother tongue for day to
+day's work, as far as possible.  Many would simply love seeing their
+computer screen showing a lot less of English, and far more of their
+own language.
+
+GNU `gettext' is an important step for the GNU Translation Project, as
+bit is an asset on which we may build many other steps. This package
+offers to programmers, translators, and even users, a well integrated
+set of tools and documentation. Specifically, the GNU `gettext'
+utilities are a set of tools that provides a framework to help other
+GNU packages produce multi-lingual messages.")
+    (license "GPLv3"))) ; some files are under GPLv2+