summary refs log tree commit diff
path: root/distro/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:02 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:26 +0100
commite76bdf8b87920b87a2a2e728c2e40ff24ca39ffe (patch)
treeffcb4e08f2d00acaf670c8344e6a12da6ea39772 /distro/packages/guile.scm
parent81dbd783bd9afabd1d8720c9b60a6a93492bb581 (diff)
downloadguix-e76bdf8b87920b87a2a2e728c2e40ff24ca39ffe.tar.gz
build: Clearly mark Nixpkgs as optional.
* configure.ac: Always show the result of checking for Nixpkgs.  Don't
  warn when Nixpkgs is not found.
* Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Remove `--with-nixpkgs'
  flag.
* guix/utils.scm (%nixpkgs-directory): Use either the compile-time or
  the run-time `NIXPKGS' environment variable.
* release.nix (jobs.tarball, jobs.build): Remove `--with-nixpkgs'
  configure flag.
* README: Mark Nixpkgs as optional.

* distro/packages/databases.scm, distro/packages/guile.scm,
  distro/packages/typesetting.scm: Change uses of `nixpkgs-derivation*'
  to `nixpkgs-derivation', to avoid failing at compile-time.
Diffstat (limited to 'distro/packages/guile.scm')
-rw-r--r--distro/packages/guile.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/distro/packages/guile.scm b/distro/packages/guile.scm
index 8c25ee9af6..464379bc47 100644
--- a/distro/packages/guile.scm
+++ b/distro/packages/guile.scm
@@ -45,7 +45,7 @@ or 2.0."
                "1svlyk5pm4fsdp2g7n6qffdl6fdggxnlicj0jn9s4lxd63gzxy1n"))))
    (build-system gnu-build-system)
    (native-inputs `(("pkgconfig" ,pkg-config)
-                    ("gperf" ,(nixpkgs-derivation* "gperf"))))
+                    ("gperf" ,(nixpkgs-derivation "gperf"))))
    (inputs `(("guile" ,guile)))
    (description "Guile-Reader, a simple framework for building readers for
 GNU Guile")