summary refs log tree commit diff
path: root/distro/packages/ncurses.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
commitc089511288820cfb3efc5295e572be24aa83f068 (patch)
treeece62d1d06ee146feb59f60fe5c4d307542205cc /distro/packages/ncurses.scm
parent8722e80e82f6b2ca326b20a4b3179ed25115ce4f (diff)
downloadguix-c089511288820cfb3efc5295e572be24aa83f068.tar.gz
build-system/gnu: Patch shebangs in all the source; patch SHELL in makefiles.
* guix/build/utils.scm (call-with-ascii-input-file): New procedure.
  (patch-shebang): Use it.
  (patch-makefile-SHELL): New procedure.
* guix/build/gnu-build-system.scm (patch-source-shebangs): Patch all the
  files, not just executables; remove `po/Makefile.in.in' patching.
  (patch-generated-files): Rename to...
  (patch-generated-file-shebangs): ... this.  Patch executables and
  makefiles.
  (%standard-phases): Adjust accordingly.

* distro/packages/autotools.scm (libtool): Remove call to `patch-shebang'.
* distro/packages/base.scm (gcc-4.7): Likewise.
  (guile-final): Remove hack to skip `test-command-line-encoding2'.
* distro/packages/bash.scm (bash): Remove `pre-configure-phase'.
* distro/packages/readline.scm (readline): Likewise.
* distro/packages/ncurses.scm (ncurses): Remove `pre-install-phase'.
Diffstat (limited to 'distro/packages/ncurses.scm')
-rw-r--r--distro/packages/ncurses.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/distro/packages/ncurses.scm b/distro/packages/ncurses.scm
index 868222ef83..8bde3c1989 100644
--- a/distro/packages/ncurses.scm
+++ b/distro/packages/ncurses.scm
@@ -28,9 +28,6 @@
          '(lambda _
             (substitute* (find-files "." "Makefile.in")
               (("^SHELL[[:blank:]]*=.*$") ""))))
-        (pre-install-phase
-         '(lambda _
-            (for-each patch-shebang (find-files "." "\\.sh$"))))
         (post-install-phase
          '(lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
@@ -93,10 +90,7 @@
                      (alist-cons-before
                       'configure 'patch-makefile-SHELL
                       ,patch-makefile-phase
-                      (alist-cons-before
-                       'install 'pre-install-phase
-                       ,pre-install-phase
-                       %standard-phases)))
+                      %standard-phases))
 
            ;; The `ncursesw5-config' has a #!/bin/sh that we don't want to
            ;; patch, to avoid retaining a reference to the build-time Bash.