summary refs log tree commit diff
path: root/distro/packages/pth.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/pth.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/pth.scm')
-rw-r--r--distro/packages/pth.scm61
1 files changed, 0 insertions, 61 deletions
diff --git a/distro/packages/pth.scm b/distro/packages/pth.scm
deleted file mode 100644
index 4c52079544..0000000000
--- a/distro/packages/pth.scm
+++ /dev/null
@@ -1,61 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages pth)
-  #:use-module (guix licenses)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public pth
-  (package
-    (name "pth")
-    (version "2.0.7")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/pth/pth-" version
-                          ".tar.gz"))
-      (sha256
-       (base32
-        "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
-    (build-system gnu-build-system)
-    (arguments '(#:parallel-build? #f))
-    (home-page "http://www.gnu.org/software/pth")
-    (synopsis "The GNU Portable Threads library")
-    (description
-     "Pth is a very portable POSIX/ANSI-C based library for Unix
-platforms which provides non-preemptive priority-based scheduling for
-multiple threads of execution (aka ``multithreading'') inside
-event-driven applications. All threads run in the same address space of
-the server application, but each thread has it's own individual
-program-counter, run-time stack, signal mask and errno variable.
-
-The thread scheduling itself is done in a cooperative way, i.e., the
-threads are managed by a priority- and event-based non-preemptive
-scheduler. The intention is that this way one can achieve better
-portability and run-time performance than with preemptive
-scheduling. The event facility allows threads to wait until various
-types of events occur, including pending I/O on file descriptors,
-asynchronous signals, elapsed timers, pending I/O on message ports,
-thread and process termination, and even customized callback functions.
-
-Additionally Pth provides an optional emulation API for POSIX.1c
-threads (\"Pthreads\") which can be used for backward compatibility to
-existing multithreaded applications.")
-    (license lgpl2.1+)))