summary refs log tree commit diff
path: root/distro/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/python.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/python.scm')
-rw-r--r--distro/packages/python.scm58
1 files changed, 0 insertions, 58 deletions
diff --git a/distro/packages/python.scm b/distro/packages/python.scm
deleted file mode 100644
index 5692cd5bd5..0000000000
--- a/distro/packages/python.scm
+++ /dev/null
@@ -1,58 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages python)
-  #:use-module ((guix licenses) #:select (psfl))
-  #:use-module (distro packages compression)
-  #:use-module (distro packages openssl)
-  #:use-module (distro packages base)
-  #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
-
-(define-public python
-  (package
-    (name "python")
-    (version "2.7.3")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "http://www.python.org/ftp/python/"
-                          version "/Python-" version ".tar.xz"))
-      (sha256
-       (base32
-        "11f9aw855lrmknr6c82gm1ijr3n0smc6idyp94y7774yivjnplv1"))))
-    (build-system gnu-build-system)
-    (arguments `(#:tests? #f)) ; XXX: some tests fail
-    (inputs
-     `(("zlib" ,zlib)
-       ("openssl" ,openssl)
-       ("bzip2" ,bzip2)))
-    (home-page "http://python.org")
-    (synopsis
-     "Python, a high-level dynamically-typed programming language")
-    (description
-     "Python is a remarkably powerful dynamic programming language that
-is used in a wide variety of application domains.  Some of its key
-distinguishing features include: clear, readable syntax; strong
-introspection capabilities; intuitive object orientation; natural
-expression of procedural code; full modularity, supporting hierarchical
-packages; exception-based error handling; and very high level dynamic
-data types.")
-    (license psfl)))