summary refs log tree commit diff
path: root/distro/packages/zile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/zile.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
distro: Change the module name space to (gnu ...).
* distro: Rename to...
* gnu: ... this.  Update module names accordingly.
* Makefile.am: Adjust accordingly.
* po/POTFILES.in: Likewise.
* distro.scm: Search for files under /gnu/packages instead of
  /distro/packages.
* gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/zile.scm')
-rw-r--r--distro/packages/zile.scm66
1 files changed, 0 insertions, 66 deletions
diff --git a/distro/packages/zile.scm b/distro/packages/zile.scm
deleted file mode 100644
index 9eae6d4b9f..0000000000
--- a/distro/packages/zile.scm
+++ /dev/null
@@ -1,66 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages zile)
-  #:use-module (guix licenses)
-  #:use-module (guix download)
-  #:use-module (guix packages)
-  #:use-module (guix build-system gnu)
-  #:use-module (distro packages bdw-gc)
-  #:use-module (distro packages perl)
-  #:use-module (distro packages help2man)
-  #:use-module (distro packages ncurses))
-
-(define-public zile
-  (package
-    (name "zile")
-    (version "2.4.9")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/zile/zile-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "0j801c28ypm924rw3lqyb6khxyslg6ycrv16wmmwcam0mk3mj6f7"))))
-    (build-system gnu-build-system)
-    (inputs
-     `(("boehm-gc" ,libgc)
-       ("ncurses" ,ncurses)
-       ("perl" ,perl)
-       ("help2man" ,help2man)))
-    (home-page "http://www.gnu.org/software/zile/")
-    (synopsis "GNU Zile, a lightweight Emacs clone")
-    (description
-     "GNU Zile, which is a lightweight Emacs clone.  Zile is short
-for Zile Is Lossy Emacs.  Zile has been written to be as
-similar as possible to Emacs; every Emacs user should feel at
-home.
-
-Zile has all of Emacs's basic editing features: it is 8-bit
-clean (though it currently lacks Unicode support), and the
-number of editing buffers and windows is only limited by
-available memory and screen space respectively.  Registers,
-minibuffer completion and auto fill are available.  Function
-and variable names are identical with Emacs's (except those
-containing the word \"emacs\", which instead contain the word
-\"zile\"!).
-
-However, all of this is packed into a program which typically
-compiles to about 130Kb.")
-    (license gpl3+)))