summary refs log tree commit diff
path: root/distro/packages
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-12-18 22:34:52 +0000
committerNikita Karetnikov <nikita@karetnikov.org>2012-12-18 22:44:18 +0000
commit3b48f78c858a0e7fe53d7917c9bc7ef5aafc8f3e (patch)
tree6de940f86620426d0de5c868ff34b1a38ee50080 /distro/packages
parentd8989c2394dc90cdc1bbd1f97bf6de5b1b8aed0e (diff)
downloadguix-3b48f78c858a0e7fe53d7917c9bc7ef5aafc8f3e.tar.gz
distro: Add Libusb.
* distro/packages/libusb.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro/packages')
-rw-r--r--distro/packages/libusb.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/distro/packages/libusb.scm b/distro/packages/libusb.scm
new file mode 100644
index 0000000000..9f21945106
--- /dev/null
+++ b/distro/packages/libusb.scm
@@ -0,0 +1,44 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages libusb)
+  #:use-module (distro)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public libusb
+  (package
+    (name "libusb")
+    (version "1.0.9")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://sourceforge/libusb/libusb-1.0/"
+                          "libusb-" version "/libusb-" version ".tar.bz2"))
+      (sha256
+       (base32
+        "16sz34ix6hw2wwl3kqx6rf26fg210iryr68wc439dc065pffw879"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.libusb.org")
+    (synopsis "Libusb, a user-space USB library")
+    (description
+     "Libusb is a library that gives applications easy access to USB
+devices on various operating systems.")
+    (license lgpl2.1+)))
\ No newline at end of file