summary refs log tree commit diff
path: root/distro/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-17 17:51:33 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-17 23:25:25 +0200
commiteb1db76e34e19bd539955a1019e38c5d8b5d02e7 (patch)
tree974d322acd404f734a007fecae63799fc53705bb /distro/packages
parentb7f280ee3e33f87080b751543b6c5ab16955687c (diff)
downloadguix-eb1db76e34e19bd539955a1019e38c5d8b5d02e7.tar.gz
distro: Add patch to allow the bootstrap Guile to work without iconv.
* distro/patches/guile-default-utf8.patch: New file.
* Makefile.am (dist_patch_DATA): Add it.

* distro/packages/base.scm (%guile-static): Use it.
  (%guile-static-stripped): Add call to `remove-store-references'.
Diffstat (limited to 'distro/packages')
-rw-r--r--distro/packages/base.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/distro/packages/base.scm b/distro/packages/base.scm
index 39044e1c30..ad3c4882a2 100644
--- a/distro/packages/base.scm
+++ b/distro/packages/base.scm
@@ -2005,6 +2005,8 @@ store.")
                  (inputs
                   `(("patch/relocatable"
                      ,(search-patch "guile-relocatable.patch"))
+                    ("patch/utf8"
+                     ,(search-patch "guile-default-utf8.patch"))
                     ,@(package-inputs guile-2.0)))
                  (arguments
                   `(;; When `configure' checks for ltdl availability, it
@@ -2031,7 +2033,8 @@ store.")
                     ;; Allow Guile to be relocated, as is needed during
                     ;; bootstrap.
                     #:patches
-                    (list (assoc-ref %build-inputs "patch/relocatable"))
+                    (list (assoc-ref %build-inputs "patch/relocatable")
+                          (assoc-ref %build-inputs "patch/utf8"))
 
                     ;; There are uses of `dynamic-link' in
                     ;; {foreign,coverage}.test that don't fly here.
@@ -2094,6 +2097,7 @@ store.")
            (mkdir (string-append out "/bin"))
            (copy-file (string-append in "/bin/guile")
                       (string-append out "/bin/guile"))
+           (remove-store-references (string-append out "/bin/guile"))
            #t))))
     (inputs `(("guile" ,%guile-static)))))