summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-28 01:24:34 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-28 01:24:34 +0200
commite3ce5d709f3ba6a3f3a94a24c20a9cd87e6bd07d (patch)
tree8b680281ba2e3f01d957d76f7918c30ce3b3ba0f /distro
parente1e8874ee82cd9e7e6a8f04bb5144eeb69610b7f (diff)
downloadguix-e3ce5d709f3ba6a3f3a94a24c20a9cd87e6bd07d.tar.gz
Add a declarative packaging layer.
* Makefile.am (MODULES): Add `guix/packages.scm' and `distro/base.scm'.
  (TESTS): Add `tests/packages.scm'.
  (EXTRA_DIST): New variable.

* guix/packages.scm, distro/base.scm, tests/packages.scm: New files.

* guix/http.scm (http-fetch): Make `name' an optional argument, to match
  the expectations of `package-source-derivation'.
Diffstat (limited to 'distro')
-rw-r--r--distro/base.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/distro/base.scm b/distro/base.scm
new file mode 100644
index 0000000000..d830d6efef
--- /dev/null
+++ b/distro/base.scm
@@ -0,0 +1,49 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro base)
+  #:use-module (guix packages)
+  #:use-module (guix http)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix utils))
+
+;;; Commentary:
+;;;
+;;; A Guix-based distribution.
+;;;
+;;; Code:
+
+(define-public hello
+  (package
+   (name "hello")
+   (version "2.8")
+   (source (source
+            (method http-fetch)
+            (uri "http://ftp.gnu.org/gnu/hello/hello-2.8.tar.gz")
+            (sha256
+             (nix-base32-string->bytevector  ; TODO: make conversion implicit
+              "0wqd8sjmxfskrflaxywc7gqw7sfawrfvdxd9skxawzfgyy0pzdz6"))))
+   (build-system gnu-build-system)
+   (arguments '(#:configure-flags
+                `("--disable-dependency-tracking"
+                  ,(string-append "--with-gawk="  ; for illustration purposes
+                                 (assoc-ref %build-inputs "gawk")))))
+   (inputs `(("gawk" ,(nixpkgs-derivation "gawk"))))
+   (description "GNU Hello")
+   (long-description "Yeah...")
+   (license "GPLv3+")))