summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-19 21:42:11 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-19 21:42:11 +0100
commitcc8e5e25b4bc409b9dddfc0fe09b1958b6f7ae9e (patch)
tree7b50b4a51292c22aa28a5b231b256ebe6ab3e0fa /distro
parent1df895b00b8d1912c152d59cf742cd49f43747cd (diff)
downloadguix-cc8e5e25b4bc409b9dddfc0fe09b1958b6f7ae9e.tar.gz
distro: Add GNU help2man.
* distro/packages/help2man.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/help2man.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/distro/packages/help2man.scm b/distro/packages/help2man.scm
new file mode 100644
index 0000000000..51896f7704
--- /dev/null
+++ b/distro/packages/help2man.scm
@@ -0,0 +1,51 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages help2man)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
+  #:use-module (distro packages perl))
+
+(define-public help2man
+  (package
+    (name "help2man")
+    (version "1.40.8")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/help2man/help2man-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "0s6phazn8jgvpbsby8kj2m58rj1zjghi1aipvamh8af226ssqfzj"))))
+    (build-system gnu-build-system)
+    (arguments `(;; There's no `check' target.
+                 #:tests? #f))
+    (inputs
+     `(("perl" ,perl)
+       ;; TODO: Add these optional dependencies.
+       ;; ("perl-LocaleGettext" ,perl-LocaleGettext)
+       ;; ("gettext" ,gettext)
+       ))
+    (home-page "http://www.gnu.org/software/help2man/")
+    (synopsis "GNU help2man generates man pages from `--help' output")
+    (description
+     "help2man produces simple manual pages from the ‘--help’ and
+‘--version’ output of other commands.")
+    (license "GPLv3+")))