summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-07 21:30:45 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-07 21:30:45 +0100
commit708d0ceb5067f81301d0f584142bfa733fbf0ff1 (patch)
treefeb6d93b7ed4d70cdee136754e6f7084ac75f477 /distro
parent4e6b699d50b7c7b499a951182d0d8458182bb79e (diff)
downloadguix-708d0ceb5067f81301d0f584142bfa733fbf0ff1.tar.gz
distro: Add GNU Aspell.
* distro/packages/aspell.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/aspell.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/distro/packages/aspell.scm b/distro/packages/aspell.scm
new file mode 100644
index 0000000000..a4c14c092c
--- /dev/null
+++ b/distro/packages/aspell.scm
@@ -0,0 +1,54 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages aspell)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses)
+  #:use-module (distro packages perl))
+
+(define-public aspell
+  (package
+    (name "aspell")
+    (version "0.60.6.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/aspell/aspell-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))))
+    (build-system gnu-build-system)
+    (inputs `(("perl" ,perl)))
+    (home-page "http://aspell.net/")
+    (synopsis
+     "GNU Aspell, A spell checker for many languages")
+    (description
+     "GNU Aspell is a free spell checker designed to eventually replace
+Ispell.  It can either be used as a library or as an independent spell
+checker.  Its main feature is that it does a superior job of suggesting
+possible replacements for a misspelled word than just about any other
+spell checker out there for the English language.  Unlike Ispell, Aspell
+can also easily check documents in UTF-8 without having to use a special
+dictionary.  Aspell will also do its best to respect the current locale
+setting.  Other advantages over Ispell include support for using
+multiple dictionaries at once and intelligently handling personal
+dictionaries when more than one Aspell process is open at once.")
+    (license lgpl2.1+)))