summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-13 21:44:57 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-13 21:44:57 +0100
commit7543f8653bf668e232b6ea7382abf6d40313f014 (patch)
tree84a6542ea3df2f136f2954d689394d742736396a /distro
parent2e659827253d1d58176437ec37cbcee804130c56 (diff)
downloadguix-7543f8653bf668e232b6ea7382abf6d40313f014.tar.gz
distro: Add GNU Libtasn1 and GnuTLS.
* distro/packages/gnutls.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/gnutls.scm88
1 files changed, 88 insertions, 0 deletions
diff --git a/distro/packages/gnutls.scm b/distro/packages/gnutls.scm
new file mode 100644
index 0000000000..7cc64910d0
--- /dev/null
+++ b/distro/packages/gnutls.scm
@@ -0,0 +1,88 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages gnutls)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (distro packages base)
+  #:use-module (distro packages compression)
+  #:use-module (distro packages nettle)
+  #:use-module (distro packages guile)
+  #:use-module (distro packages perl))
+
+(define-public libtasn1
+  (package
+    (name "libtasn1")
+    (version "3.0")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/libtasn1/libtasn1-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "00czfs2hlxb1nrnqicvwpm4ybpwg3hg5yj0a2nf13zrgkfdlkjzi"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.gnu.org/software/libtasn1/")
+    (synopsis "GNU Libtasn1, an ASN.1 library")
+    (description
+     "Libtasn1 is the ASN.1 library used by GnuTLS, GNU Shishi and some
+other packages.  The goal of this implementation is to be highly
+portable, and only require an ANSI C89 platform.")
+    (license "LGPLv2+")))
+
+(define-public gnutls
+  (package
+    (name "gnutls")
+    (version "3.1.3")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append
+            "mirror://gnu/gnutls/gnutls-"
+            version
+            ".tar.xz"))
+      (sha256
+       (base32
+        "0fff9frz0ycbnppfn0w4a2s9x27k21l4hh9zbax3v7a8cg33dcpw"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("guile" ,guile-2.0)
+       ;; ("lzo" ,lzo)
+       ("zlib" ,zlib)
+       ("perl" ,perl)))
+    (propagated-inputs
+     `(("libtasn1" ,libtasn1)
+       ("nettle" ,nettle)))
+    (home-page "http://www.gnu.org/software/gnutls/")
+    (synopsis
+     "The GNU Transport Layer Security Library")
+    (description
+     "GnuTLS is a project that aims to develop a library which provides
+a secure layer, over a reliable transport layer. Currently the GnuTLS
+library implements the proposed standards by the IETF's TLS working
+group.
+
+Quoting from the TLS protocol specification:
+
+\"The TLS protocol provides communications privacy over the
+Internet. The protocol allows client/server applications to communicate
+in a way that is designed to prevent eavesdropping, tampering, or
+message forgery.\"")
+    (license "LGPLv2.1+")))