summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-21 22:31:25 +0100
commitc089511288820cfb3efc5295e572be24aa83f068 (patch)
treeece62d1d06ee146feb59f60fe5c4d307542205cc /distro
parent8722e80e82f6b2ca326b20a4b3179ed25115ce4f (diff)
downloadguix-c089511288820cfb3efc5295e572be24aa83f068.tar.gz
build-system/gnu: Patch shebangs in all the source; patch SHELL in makefiles.
* guix/build/utils.scm (call-with-ascii-input-file): New procedure.
  (patch-shebang): Use it.
  (patch-makefile-SHELL): New procedure.
* guix/build/gnu-build-system.scm (patch-source-shebangs): Patch all the
  files, not just executables; remove `po/Makefile.in.in' patching.
  (patch-generated-files): Rename to...
  (patch-generated-file-shebangs): ... this.  Patch executables and
  makefiles.
  (%standard-phases): Adjust accordingly.

* distro/packages/autotools.scm (libtool): Remove call to `patch-shebang'.
* distro/packages/base.scm (gcc-4.7): Likewise.
  (guile-final): Remove hack to skip `test-command-line-encoding2'.
* distro/packages/bash.scm (bash): Remove `pre-configure-phase'.
* distro/packages/readline.scm (readline): Likewise.
* distro/packages/ncurses.scm (ncurses): Remove `pre-install-phase'.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/autotools.scm1
-rw-r--r--distro/packages/base.scm31
-rw-r--r--distro/packages/bash.scm16
-rw-r--r--distro/packages/ncurses.scm8
-rw-r--r--distro/packages/readline.scm14
5 files changed, 11 insertions, 59 deletions
diff --git a/distro/packages/autotools.scm b/distro/packages/autotools.scm
index 1c01b3d3db..171855b937 100644
--- a/distro/packages/autotools.scm
+++ b/distro/packages/autotools.scm
@@ -118,7 +118,6 @@ Standards.  Automake requires the use of Autoconf.")
                             (string-append "-j" ncores)))
 
                    ;; Path references to /bin/sh.
-                   (patch-shebang "libtoolize")
                    (let ((bash (assoc-ref inputs "bash")))
                      (substitute* "tests/testsuite"
                        (("/bin/sh")
diff --git a/distro/packages/base.scm b/distro/packages/base.scm
index 0a937486a4..0289b6c688 100644
--- a/distro/packages/base.scm
+++ b/distro/packages/base.scm
@@ -428,9 +428,6 @@ BFD (Binary File Descriptor) library, `gprof', `nm', `strip', etc.")
 ~a~%"
                             libc line))))
 
-               ;; Adjust hard-coded #!/bin/sh.
-               (patch-shebang "gcc/exec-tool.in")
-
                ;; Don't retain a dependency on the build-time sed.
                (substitute* "fixincludes/fixincl.x"
                  (("static char const sed_cmd_z\\[\\] =.*;")
@@ -967,29 +964,11 @@ store.")
   ;; FIXME: The Libtool used here, specifically its `bin/libtool' script,
   ;; holds a dependency on the bootstrap Binutils.  Use multiple outputs for
   ;; Libtool, so that that dependency is isolated in the "bin" output.
-  (let ((guile (package (inherit guile-2.0/fixed)
-                 (arguments
-                  (substitute-keyword-arguments
-                      (package-arguments guile-2.0/fixed)
-                    ((#:phases phases)
-                     `(alist-cons-before
-                       'patch-source-shebangs 'delete-encoded-test
-                       (lambda* (#:key inputs #:allow-other-keys)
-                         ;; %BOOTSTRAP-GUILE doesn't know about encodings other
-                         ;; than UTF-8.  That test declares an ISO-8859-1
-                         ;; encoding, which prevents `patch-shebang' from
-                         ;; working, so skip it.
-                         (call-with-output-file
-                             "test-suite/standalone/test-command-line-encoding2"
-                           (lambda (p)
-                             (format p "#!~a/bin/bash\nexit 77"
-                                     (assoc-ref inputs "bash")))))
-                       ,phases)))))))
-    (package-with-bootstrap-guile
-     (package-with-explicit-inputs guile
-                                   %boot4-inputs
-                                   (current-source-location)
-                                   #:guile %bootstrap-guile))))
+  (package-with-bootstrap-guile
+   (package-with-explicit-inputs guile-2.0/fixed
+                                 %boot4-inputs
+                                 (current-source-location)
+                                 #:guile %bootstrap-guile)))
 
 (define-public ld-wrapper
   ;; The final `ld' wrapper, which uses the final Guile.
diff --git a/distro/packages/bash.scm b/distro/packages/bash.scm
index c2022fcf95..f32293d82f 100644
--- a/distro/packages/bash.scm
+++ b/distro/packages/bash.scm
@@ -33,13 +33,6 @@
                                  "-DNON_INTERACTIVE_LOGIN_SHELLS"
                                  "-DSSH_SOURCE_BASHRC")
                                " "))
-        (pre-configure-phase
-         '(lambda* (#:key inputs #:allow-other-keys)
-            ;; Use the right shell for makefiles.
-            (let ((bash (assoc-ref inputs "bash")))
-              (substitute* "configure"
-                (("MAKE_SHELL=[^ ]+")
-                 (format #f "MAKE_SHELL=~a/bin/bash" bash))))))
         (post-install-phase
          '(lambda* (#:key outputs #:allow-other-keys)
             ;; Add a `bash' -> `sh' link.
@@ -80,12 +73,9 @@
         ;; for now.
         #:tests? #f
 
-        #:phases (alist-cons-before
-                  'configure 'pre-configure
-                  ,pre-configure-phase
-                  (alist-cons-after 'install 'post-install
-                                    ,post-install-phase
-                                    %standard-phases))))
+        #:phases (alist-cons-after 'install 'post-install
+                                   ,post-install-phase
+                                   %standard-phases)))
      (synopsis "GNU Bourne-Again Shell")
      (description
       "Bash is the shell, or command language interpreter, that will appear in
diff --git a/distro/packages/ncurses.scm b/distro/packages/ncurses.scm
index 868222ef83..8bde3c1989 100644
--- a/distro/packages/ncurses.scm
+++ b/distro/packages/ncurses.scm
@@ -28,9 +28,6 @@
          '(lambda _
             (substitute* (find-files "." "Makefile.in")
               (("^SHELL[[:blank:]]*=.*$") ""))))
-        (pre-install-phase
-         '(lambda _
-            (for-each patch-shebang (find-files "." "\\.sh$"))))
         (post-install-phase
          '(lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
@@ -93,10 +90,7 @@
                      (alist-cons-before
                       'configure 'patch-makefile-SHELL
                       ,patch-makefile-phase
-                      (alist-cons-before
-                       'install 'pre-install-phase
-                       ,pre-install-phase
-                       %standard-phases)))
+                      %standard-phases))
 
            ;; The `ncursesw5-config' has a #!/bin/sh that we don't want to
            ;; patch, to avoid retaining a reference to the build-time Bash.
diff --git a/distro/packages/readline.scm b/distro/packages/readline.scm
index bf542e90b5..8e2a4cbb5d 100644
--- a/distro/packages/readline.scm
+++ b/distro/packages/readline.scm
@@ -36,14 +36,7 @@
               (for-each (lambda (f) (chmod f #o755))
                         (find-files lib "\\.so"))
               (for-each (lambda (f) (chmod f #o644))
-                        (find-files lib "\\.a")))))
-        (pre-configure-phase
-         '(lambda* (#:key inputs #:allow-other-keys)
-            ;; Use the right shell for makefiles.
-            (let ((bash (assoc-ref inputs "bash")))
-              (substitute* "configure"
-                (("^MAKE_SHELL=.*")
-                 (format #f "MAKE_SHELL=~a/bin/bash" bash)))))))
+                        (find-files lib "\\.a"))))))
     (package
       (name "readline")
       (version "6.2")
@@ -69,10 +62,7 @@
                    #:phases (alist-cons-after
                              'install 'post-install
                              ,post-install-phase
-                             (alist-cons-before
-                              'configure 'pre-configure
-                              ,pre-configure-phase
-                              %standard-phases))))
+                             %standard-phases)))
       (synopsis "GNU Readline, a library for interactive line editing")
       (description
        "The GNU Readline library provides a set of functions for use by