summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-26 21:58:48 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-26 22:00:58 +0200
commit1f455fdca60c90710322d99ac529a31d71764a0d (patch)
tree0c16dde04916403e121efe843ab4227a0aad0b0a /distro
parent8ffae202acca491c7ebceb094018c79a6d5f2b3a (diff)
downloadguix-1f455fdca60c90710322d99ac529a31d71764a0d.tar.gz
distro: Rename (distro ...) to (distro packages ...).
* distro/base.scm, distro/ld-wrapper.scm: Move to `distro/packages'.
  Adjust LD-WRAPPER-BOOT3 input file name accordingly.
* Makefile.am (MODULES): Adjust accordingly.
* distro.scm (%distro-module-directory): Change to "/distro/packages".
* guix/build-system/gnu.scm (standard-inputs): Change module name
  to (distro packages base).
* tests/packages.scm (test-packages): Likewise.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/base.scm (renamed from distro/base.scm)5
-rw-r--r--distro/packages/ld-wrapper.scm (renamed from distro/ld-wrapper.scm)4
2 files changed, 5 insertions, 4 deletions
diff --git a/distro/base.scm b/distro/packages/base.scm
index bf49d02f20..67b8b1c602 100644
--- a/distro/base.scm
+++ b/distro/packages/base.scm
@@ -16,7 +16,7 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (distro base)
+(define-module (distro packages base)
   #:use-module (distro)
   #:use-module (guix packages)
   #:use-module (guix ftp)
@@ -1676,7 +1676,8 @@ exec ~a/bin/~a-gcc -B~a/lib -Wl,-dynamic-linker -Wl,~a/lib/~a \"$@\"~%"
     (build-system trivial-build-system)
     (inputs `(("binutils" ,binutils-final)
               ("guile"   ,(nixpkgs-derivation* "guile"))
-              ("wrapper" ,(search-path %load-path "distro/ld-wrapper.scm"))))
+              ("wrapper" ,(search-path %load-path
+                                       "distro/packages/ld-wrapper.scm"))))
     (arguments
      `(#:modules ((guix build utils))
        #:builder (begin
diff --git a/distro/ld-wrapper.scm b/distro/packages/ld-wrapper.scm
index 9d3e8008b3..9b8a09f067 100644
--- a/distro/ld-wrapper.scm
+++ b/distro/packages/ld-wrapper.scm
@@ -7,7 +7,7 @@
 # Use `load-compiled' because `load' (and `-l') doesn't otherwise load our
 # .go file (see <http://bugs.gnu.org/12519>).
 
-main="(@ (distro ld-wrapper) ld-wrapper)"
+main="(@ (distro packages ld-wrapper) ld-wrapper)"
 exec @GUILE@ -c "(load-compiled \"$0.go\") (apply $main (cdr (command-line)))" "$@"
 !#
 ;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
@@ -28,7 +28,7 @@ exec @GUILE@ -c "(load-compiled \"$0.go\") (apply $main (cdr (command-line)))" "
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (distro ld-wrapper)
+(define-module (distro packages ld-wrapper)
   #:use-module (srfi srfi-1)
   #:export (ld-wrapper))