summary refs log tree commit diff
path: root/distro
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-22 17:57:37 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-22 17:57:37 +0100
commitcf153fc4726c616f5c5608797f02bb71b573140b (patch)
tree2e1a93f1ac4f8ba7714e3980b650353b2edb3303 /distro
parent30c40755fc2e8e2f5e1ef01f0115f7d2f5a9a4f4 (diff)
downloadguix-cf153fc4726c616f5c5608797f02bb71b573140b.tar.gz
distro: Add GNU Bison.
* distro/packages/bison.scm: New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'distro')
-rw-r--r--distro/packages/bison.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/distro/packages/bison.scm b/distro/packages/bison.scm
new file mode 100644
index 0000000000..500fa3979d
--- /dev/null
+++ b/distro/packages/bison.scm
@@ -0,0 +1,56 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages bison)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (distro packages m4)
+  #:use-module (distro packages perl))
+
+(define-public bison
+  (package
+    (name "bison")
+    (version "2.6.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/bison/bison-"
+                          version ".tar.xz"))
+      (sha256
+       (base32
+        "0y9svfkbw8jc8yv280hqzilpvlwg60gayck83jj98djmzaxr1w86"))))
+    (build-system gnu-build-system)
+    (inputs `(("perl" ,perl)))
+    (propagated-inputs `(("m4" ,m4)))
+    (home-page "http://www.gnu.org/software/bison/")
+    (synopsis
+     "GNU Bison, a Yacc-compatible parser generator")
+    (description
+     "Bison is a general-purpose parser generator that converts an
+annotated context-free grammar into an LALR(1) or GLR parser for
+that grammar.  Once you are proficient with Bison, you can use
+it to develop a wide range of language parsers, from those used
+in simple desk calculators to complex programming languages.
+
+Bison is upward compatible with Yacc: all properly-written Yacc
+grammars ought to work with Bison with no change.  Anyone
+familiar with Yacc should be able to use Bison with little
+trouble.  You need to be fluent in C or C++ programming in order
+to use Bison.")
+    (license "GPLv3+")))